PPCGeeks Forums HTC Arrive HTC HD2 HTC Thunderbolt HTC Touch Pro 2 HTC Evo 4G HTC Evo 3D Samsung Galaxy S II Motorola Droid X Apple iPhone Blackberry
Go Back   PPCGeeks > Windows Mobile > WM HTC Devices > HTC Diamond

Notices



Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 10-14-2008, 04:56 PM
snovvman's Avatar
Regular 'Geeker
Offline
Pocket PC: Most new phones from these carriers except BBs (don't like RIM).
Carrier: Sprint, ATT, Verizon AND T-Mobile. Yes, you read right.
 
Join Date: Jun 2008
Posts: 456
Reputation: 1190
snovvman is halfway to VIP status based on repsnovvman is halfway to VIP status based on repsnovvman is halfway to VIP status based on repsnovvman is halfway to VIP status based on repsnovvman is halfway to VIP status based on repsnovvman is halfway to VIP status based on repsnovvman is halfway to VIP status based on repsnovvman is halfway to VIP status based on repsnovvman is halfway to VIP status based on rep
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Solution on delay answer when data on (no hard reset needed!)

I had the same problem as many others: When data is on (active or dormant, EVDO or 1xRTT (dormant), it takes many seconds for the calls to be answered, the phone keeps ringing even though I pressed the answer key.

It does appear that one of the tweak applications created the problem, at least for some. After much research, this may be it...

Take a look at your HKLM/Comm/ConnMgr/Planner/Settings/SuspendResume

It is a multi-sz value and should be #777. If it shows anything like ~GPRS or something containing GPRS, change it back to #777 and soft reset.

When I used PHM Regedit to correct this, it seemed to crash (the reg editor never crashed before now). I had to use SKTool's regedit. I will create an export if this will help you.

Once I changed it back to #777, I can answer the call immediately when data is on, time and time again. Prior to this, there was a significant delay.

Please let me know if this works for you.


Edit: I also noticed that, with this correction, after the call, the data goes back to dormant rather than disconnected.

Last edited by snovvman; 10-15-2008 at 12:51 PM.
Reply With Quote
This post has been thanked 66 times.
  #2 (permalink)  
Old 10-14-2008, 05:00 PM
JaxDreamFunding's Avatar
PPCGeeks Regular
Offline
Pocket PC: Treo Pro
Carrier: SPrint
 
Join Date: Jul 2007
Posts: 116
Reputation: 35
JaxDreamFunding is just getting started
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Send a message via AIM to JaxDreamFunding Send a message via MSN to JaxDreamFunding
Re: Possible solution on delay answer when data on (no hard reset needed!)

I will try this and see if it help! My fingers are crossed...
__________________
Scott A. Roberts
Reply With Quote
  #3 (permalink)  
Old 10-14-2008, 05:02 PM
JaxDreamFunding's Avatar
PPCGeeks Regular
Offline
Pocket PC: Treo Pro
Carrier: SPrint
 
Join Date: Jul 2007
Posts: 116
Reputation: 35
JaxDreamFunding is just getting started
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Send a message via AIM to JaxDreamFunding Send a message via MSN to JaxDreamFunding
Re: Possible solution on delay answer when data on (no hard reset needed!)

I made the change with Resco RegEdit and it did not crash...will let you know how the answer problems works after this...
Reply With Quote
  #4 (permalink)  
Old 10-14-2008, 05:16 PM
cappy's Avatar
PPCGeeks Regular
Offline
Pocket PC: Diamond
Carrier: Sprint
Location: Pa
 
Join Date: Jul 2008
Posts: 95
Reputation: 100
cappy is keeping up the good workcappy is keeping up the good work
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Possible solution on delay answer when data on (no hard reset needed!)

Quote:
Originally Posted by snovvman View Post
I had the same problem as many others: When data is on (active or dormant, EVDO or 1xRTT (dormant), it takes many seconds for the calls to be answered, the phone keeps ringing even though I pressed the answer key.

It does appear that one of the tweak applications created the problem, at least for some. After much research, this may be it...

Take a look at your HKLM/Comm/ConnMgr/Planner/Settings/SuspendResume

It is a multi-sz value and should be #777. If it shows anything like ~GPRS or something containing GPRS, change it back to #777 and soft reset.

When I used PHM Regedit to correct this, it seemed to crash (the reg editor never crashed before now). I had to use SKTool's regedit. I will create an export if this will help you.

Once I changed it back to #777, I can answer the call immediately when data is on, time and time again. Prior to this, there was a significant delay.

Please let me know if this works for you.


Edit: I also noticed that, with this correction, after the call, the data goes back to dormant rather than disconnected.
Very good Snovvman. All of the information that I have been gathering tells me that you have found it, including your last comment about the data connection going back on. That was one of the symptoms. You found what no one else has and have been able to reproduce the solution. I cannot try it because I did already reset, but I hope others will try it and report back.


Edit: I think I am going to re-install Advanced Config and see what settings may be the culprit. There is an active thread on Advanced Config at XDA. You may want to let Schapps know what you found once you get some confirmation that this has solved others' answer problems.

Edit2: I installed and ran Advanced Config. It did not change the #777 value and there is nothing obvious under the phone settings. If it is in Advanced Config, it is probably a value that the user changes manually.

Last edited by cappy; 10-14-2008 at 06:01 PM.
Reply With Quote
  #5 (permalink)  
Old 10-14-2008, 06:09 PM
snovvman's Avatar
Regular 'Geeker
Offline
Pocket PC: Most new phones from these carriers except BBs (don't like RIM).
Carrier: Sprint, ATT, Verizon AND T-Mobile. Yes, you read right.
Threadstarter
 
Join Date: Jun 2008
Posts: 456
Reputation: 1190
snovvman is halfway to VIP status based on repsnovvman is halfway to VIP status based on repsnovvman is halfway to VIP status based on repsnovvman is halfway to VIP status based on repsnovvman is halfway to VIP status based on repsnovvman is halfway to VIP status based on repsnovvman is halfway to VIP status based on repsnovvman is halfway to VIP status based on repsnovvman is halfway to VIP status based on rep
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Possible solution on delay answer when data on (no hard reset needed!)

Quote:
Originally Posted by cappy View Post
Very good Snovvman. All of the information that I have been gathering tells me that you have found it, including your last comment about the data connection going back on. That was one of the symptoms. You found what no one else has and have been able to reproduce the solution. I cannot try it because I did already reset, but I hope others will try it and report back.


Edit: I think I am going to re-install Advanced Config and see what settings may be the culprit. There is an active thread on Advanced Config at XDA. You may want to let Schapps know what you found once you get some confirmation that this has solved others' answer problems.

Edit2: I installed and ran Advanced Config. It did not change the #777 value and there is nothing obvious under the phone settings. If it is in Advanced Config, it is probably a value that the user changes manually.
Thanks for your help cappy. After I asked you for those values, I realized I had another Diamond in my car. After comparing the two's registry, it was obvious that GPRS did not belong. I came to that key because of all the posts I read at XDA. Some of the people got close, but never found the link. Clearly, this will only work for CDMA phones. I do hope it works for others. If this is shown to work, I will post at XDA.

BTW, try changing the timout value under "Connections" in Advanced Config. That may be when the registry gets changed.
Reply With Quote
This post has been thanked 1 times.
  #6 (permalink)  
Old 10-14-2008, 06:47 PM
cappy's Avatar
PPCGeeks Regular
Offline
Pocket PC: Diamond
Carrier: Sprint
Location: Pa
 
Join Date: Jul 2008
Posts: 95
Reputation: 100
cappy is keeping up the good workcappy is keeping up the good work
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Possible solution on delay answer when data on (no hard reset needed!)

Quote:
Originally Posted by snovvman View Post
Thanks for your help cappy.
BTW, try changing the timout value under "Connections" in Advanced Config. That may be when the registry gets changed.
There was no timeout setting under Data Connections, but I toggled each setting, one at a time, and reset. Did the same with Phone settings. No change to the #777 field. Also looked down the entire list of settings and nothing obvious jumped out. Schapps will know. I also checked for the problem again with a couple of incoming calls with Data On. Works fine. Once you get a few responses from others who have the problem now, you will know for sure.
Reply With Quote
  #7 (permalink)  
Old 10-14-2008, 07:04 PM
snovvman's Avatar
Regular 'Geeker
Offline
Pocket PC: Most new phones from these carriers except BBs (don't like RIM).
Carrier: Sprint, ATT, Verizon AND T-Mobile. Yes, you read right.
Threadstarter
 
Join Date: Jun 2008
Posts: 456
Reputation: 1190
snovvman is halfway to VIP status based on repsnovvman is halfway to VIP status based on repsnovvman is halfway to VIP status based on repsnovvman is halfway to VIP status based on repsnovvman is halfway to VIP status based on repsnovvman is halfway to VIP status based on repsnovvman is halfway to VIP status based on repsnovvman is halfway to VIP status based on repsnovvman is halfway to VIP status based on rep
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Possible solution on delay answer when data on (no hard reset needed!)

Quote:
Originally Posted by cappy View Post
There was no timeout setting under Data Connections, but I toggled each setting, one at a time, and reset. Did the same with Phone settings. No change to the #777 field. Also looked down the entire list of settings and nothing obvious jumped out. Schapps will know. I also checked for the problem again with a couple of incoming calls with Data On. Works fine. Once you get a few responses from others who have the problem now, you will know for sure.
In Advanced Config, choose "Menu" (right soft key), then "More Settings", then "Connections". Check the box and set it to a time of your choosing.

In this post, you indicated you used Advanced Config to set the timeout, so I thought you knew where it was.

Let me know. Thanks.
Reply With Quote
This post has been thanked 1 times.
  #8 (permalink)  
Old 10-14-2008, 07:22 PM
cappy's Avatar
PPCGeeks Regular
Offline
Pocket PC: Diamond
Carrier: Sprint
Location: Pa
 
Join Date: Jul 2008
Posts: 95
Reputation: 100
cappy is keeping up the good workcappy is keeping up the good work
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Possible solution on delay answer when data on (no hard reset needed!)

Bingo! That was it. Yes, I did know, but too many things to remember. Anyway, I made the change and it changed the SuspenseResume setting to GPRS.... Made a call to the phone with data on and the delayed answer was back! Changed back to #777 and it works fine again. I think that the guesswork is gone. This is the ticket. Change back to #777 and all should be well. Doing this does uncheck the Connection timeout. Can't have it both ways. Good job.
Reply With Quote
This post has been thanked 2 times.
  #9 (permalink)  
Old 10-14-2008, 11:17 PM
JaxDreamFunding's Avatar
PPCGeeks Regular
Offline
Pocket PC: Treo Pro
Carrier: SPrint
 
Join Date: Jul 2007
Posts: 116
Reputation: 35
JaxDreamFunding is just getting started
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Send a message via AIM to JaxDreamFunding Send a message via MSN to JaxDreamFunding
Re: Possible solution on delay answer when data on (no hard reset needed!)

I tested this this evening...and it works. I have had several phone calls and after applying this modification and all of my calls have answered immediately -- NO DELAY. Excellent fine!!! Thanks!
Reply With Quote
This post has been thanked 1 times.
  #10 (permalink)  
Old 10-15-2008, 01:12 AM
dallastx's Avatar
Regular 'Geeker
Offline
Pocket PC: Touch Pro2 Customized
Carrier: SPRINT
Location: Irving TX
 
Join Date: Sep 2008
Posts: 368
Reputation: 240
dallastx is keeping up the good workdallastx is keeping up the good workdallastx is keeping up the good work
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Possible solution on delay answer when data on (no hard reset needed!)

Do yall not have the ignore button issue? Where if you press the ignore button it dosent do anything but mute the call...You can keep pressing it as many times as you want and it want send the called to voicemail..Also if you press it, you cant get off that screen until the call hangs up or goes to VM. I checked the registry didnt see anythign strange..still saw #777. One thing i did notice when i turned of data on phone and turned back on...it start working...Im trying to reproduce this problem so i can figure out what is causing it..I know its not just my phone, this is my second Diamond. Anyone else sometime or all the time have Ignore button issue?

Last edited by dallastx; 10-15-2008 at 02:28 AM.
Reply With Quote
Reply

  PPCGeeks > Windows Mobile > WM HTC Devices > HTC Diamond

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


All times are GMT -4. The time now is 11:15 AM.


Powered by vBulletin® ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
©2012 - PPCGeeks.com