View Single Post
  #4 (permalink)  
Old 10-14-2008, 05:16 PM
cappy's Avatar
PPCGeeks Regular
Location: Pa
Join Date: Jul 2008
Posts: 95
Reputation: 100
cappy is keeping up the good workcappy is keeping up the good work
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Possible solution on delay answer when data on (no hard reset needed!)

Originally Posted by snovvman View Post
I had the same problem as many others: When data is on (active or dormant, EVDO or 1xRTT (dormant), it takes many seconds for the calls to be answered, the phone keeps ringing even though I pressed the answer key.

It does appear that one of the tweak applications created the problem, at least for some. After much research, this may be it...

Take a look at your HKLM/Comm/ConnMgr/Planner/Settings/SuspendResume

It is a multi-sz value and should be #777. If it shows anything like ~GPRS or something containing GPRS, change it back to #777 and soft reset.

When I used PHM Regedit to correct this, it seemed to crash (the reg editor never crashed before now). I had to use SKTool's regedit. I will create an export if this will help you.

Once I changed it back to #777, I can answer the call immediately when data is on, time and time again. Prior to this, there was a significant delay.

Please let me know if this works for you.

Edit: I also noticed that, with this correction, after the call, the data goes back to dormant rather than disconnected.
Very good Snovvman. All of the information that I have been gathering tells me that you have found it, including your last comment about the data connection going back on. That was one of the symptoms. You found what no one else has and have been able to reproduce the solution. I cannot try it because I did already reset, but I hope others will try it and report back.

Edit: I think I am going to re-install Advanced Config and see what settings may be the culprit. There is an active thread on Advanced Config at XDA. You may want to let Schapps know what you found once you get some confirmation that this has solved others' answer problems.

Edit2: I installed and ran Advanced Config. It did not change the #777 value and there is nothing obvious under the phone settings. If it is in Advanced Config, it is probably a value that the user changes manually.

Last edited by cappy; 10-14-2008 at 06:01 PM.
Reply With Quote