PPCGeeks Forums HTC Arrive HTC HD2 HTC Thunderbolt HTC Touch Pro 2 HTC Evo 4G HTC Evo 3D Samsung Galaxy S II Motorola Droid X Apple iPhone Blackberry
Go Back   PPCGeeks > Windows Mobile > WM HTC Devices > HTC Apache > HTC Apache Development

Notices


Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 09-11-2007, 03:27 PM
store2000's Avatar
N00b
Offline
 
Join Date: Sep 2007
Posts: 33
Reputation: 0
store2000 is a n00b
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Unrecognized USB device during ActiveSync (helmi's WM6)

First off, Helmi, you rock. Actually, the entire team of independent developers rock. Delivering where multi-million dollar carriers have failed.

Coming back, I used Helmi's WM6 build (5.2.1620) on my xv6700. I'm facing some issues like WPA-PSK not working, no voicetags/voicecommands over bluetooth, bluetooth volume low etc. But let me only address one issue here.

When I plug the phone into the mini-USB cable (no hub in the middle), I almost always get "USB device unrecognized" error in Windows XP. I've found a reliable way of working around it, which is
1) run WM5torage (make the device look like a USB drive)
2) Activate WM5torage
3) Deactivate WM5torage

Then immediately ActiveSync kick off and all is good. This is the same even if I enable/disable advanced networking functionality in settings -> connections -> usb to PC.

Does anyone know how to get rid of this error? I tried uninstalling WM5torage but I didn't see it in the remove programs list. Maybe because it came with the ROM image itself??

Thanks
Reply With Quote
  #2 (permalink)  
Old 09-11-2007, 07:05 PM
dth4310's Avatar
N00b
Offline
Pocket PC: Samsung Moment
Carrier: Sprint
Location: KS
 
Join Date: Feb 2007
Posts: 46
Reputation: 65
dth4310 is becoming a great contributor
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Send a message via Yahoo to dth4310
Same issue with same rom....actually experienced on some of the past kitchens as well.

My best luck has been with powering off the device in the cradle (while hooked up to USB) - the top right light blinks several times, then turns back on. About that time, activesync / pocketcontroller / my pc recognize the device.
Reply With Quote
  #3 (permalink)  
Old 09-11-2007, 08:08 PM
brightedge's Avatar
Regular 'Geeker
Offline
Pocket PC: Touch Pro
Carrier: Sprint
Location: Columbus, OH
 
Join Date: Feb 2007
Posts: 419
Reputation: 140
brightedge is keeping up the good workbrightedge is keeping up the good work
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
You can also try disabling "Advanced Networking" in Start > Settings > Connections > USB to PC. Also, make sure your cradle/USB cable is plugged directly into a port, not into a USB hub.
__________________
One ROM to rule them all,
One ROM to find them.
One ROM to bring them all,
And in the kitchen, bind them.
Reply With Quote
  #4 (permalink)  
Old 09-12-2007, 02:26 PM
INSTIGATOR's Avatar
Lurker
Offline
Pocket PC: SAMSUNG OMNIA
Carrier: VERIZON
 
Join Date: Sep 2007
Posts: 6
Reputation: 0
INSTIGATOR is a n00b
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Mine worked fine when I got it last week, now when I connect it says it doesn't recognize the USB DEVICE??
I looked in Start > Settings > Connections > but I don't have a USB to PC icon??
Reply With Quote
  #5 (permalink)  
Old 09-12-2007, 02:47 PM
brightedge's Avatar
Regular 'Geeker
Offline
Pocket PC: Touch Pro
Carrier: Sprint
Location: Columbus, OH
 
Join Date: Feb 2007
Posts: 419
Reputation: 140
brightedge is keeping up the good workbrightedge is keeping up the good work
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by INSTIGATOR View Post
Mine worked fine when I got it last week, now when I connect it says it doesn't recognize the USB DEVICE??
I looked in Start > Settings > Connections > but I don't have a USB to PC icon??
Are you using the latest WM6 ROM? If not, you may not have that icon. Which icons do you have?
Reply With Quote
  #6 (permalink)  
Old 09-12-2007, 03:35 PM
store2000's Avatar
N00b
Offline
Threadstarter
 
Join Date: Sep 2007
Posts: 33
Reputation: 0
store2000 is a n00b
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by brightedge View Post
You can also try disabling "Advanced Networking" in Start > Settings > Connections > USB to PC. Also, make sure your cradle/USB cable is plugged directly into a port, not into a USB hub.
Thanks but the original post indicates that I've tried this and it doesn't change the behavior.
Reply With Quote
  #7 (permalink)  
Old 09-12-2007, 05:19 PM
brightedge's Avatar
Regular 'Geeker
Offline
Pocket PC: Touch Pro
Carrier: Sprint
Location: Columbus, OH
 
Join Date: Feb 2007
Posts: 419
Reputation: 140
brightedge is keeping up the good workbrightedge is keeping up the good work
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by store2000 View Post
Thanks but the original post indicates that I've tried this and it doesn't change the behavior.
Sorry, must have missed that.
Reply With Quote
  #8 (permalink)  
Old 09-12-2007, 11:35 PM
store2000's Avatar
N00b
Offline
Threadstarter
 
Join Date: Sep 2007
Posts: 33
Reputation: 0
store2000 is a n00b
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
I flashed my device back to WM5 (verizon release). I don't see this problem anymore.

I think I'll wait till WM6 releases are more stable ...
Reply With Quote
  #9 (permalink)  
Old 09-13-2007, 04:04 PM
pcpal01's Avatar
N00b
Offline
Pocket PC: Touch Pro
Carrier: Sprint
Location: Elgin, IL
 
Join Date: Sep 2007
Posts: 32
Reputation: 130
pcpal01 is keeping up the good workpcpal01 is keeping up the good work
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Send a message via MSN to pcpal01 Send a message via Yahoo to pcpal01
Fixing Windows Device Issues with PPC

Had the same problem many time and this is what I do.

1. Click Start, click Run, type cmd.exe, and then press ENTER.
2. Type set devmgr_show_nonpresent_devices=1, and then press ENTER.
3. Type Start DEVMGMT.MSC, and then press ENTER.
4. Click View, and then click Show Hidden Devices.
5. Expand all trees one at a time and do the following.
6. Right-click the all dimmed devices, and then click Uninstall.
Reply With Quote
  #10 (permalink)  
Old 09-14-2007, 09:32 PM
jusinjusin's Avatar
Lurker
Offline
Pocket PC: 6700
Carrier: Sprint
 
Join Date: Jan 2007
Posts: 16
Reputation: 0
jusinjusin is a n00b
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
I tried both solutions, and I still get an unrecognized device
Reply With Quote
Reply

  PPCGeeks > Windows Mobile > WM HTC Devices > HTC Apache > HTC Apache Development

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


All times are GMT -4. The time now is 08:46 PM.


Powered by vBulletin® ©2000 - 2022, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
©2012 - PPCGeeks.com