PPCGeeks Forums HTC Arrive HTC HD2 HTC Thunderbolt HTC Touch Pro 2 HTC Evo 4G HTC Evo 3D Samsung Galaxy S II Motorola Droid X Apple iPhone Blackberry
Go Back   PPCGeeks > Windows Mobile > Windows Mobile Development

Notices



Closed Thread
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 06-14-2010, 06:25 PM
mzimmer74's Avatar
PPCGeeks Regular
Offline
Pocket PC: Samsung Omnia i910
Carrier: Verizon Wireless
 
Join Date: Jun 2008
Posts: 123
Reputation: 70
mzimmer74 is becoming a great contributor
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Can I use .Net v4.0?

I've decided to try my hand in some simple programming for my windows mobile 6.5 phone since I got a copy of Visual Studio 2010. However, that program compiles in .net 4.0 instead of 3.5 which is what my phone has. I've done some google searches but haven't found a .net 4.0 installer for the ppc, only for windows. Does anybody know if there is a .net 4.0 version for the ppc yet and if so where I could get it from? Another option would be to compile in 3.5 but I haven't researched that yet and don't even know if it is possible so advice there would be appreciated as well. Thanks.
__________________
Matthew Zimmer
Samsung Omnia i910 - Lioryte's 28232
  #2 (permalink)  
Old 06-14-2010, 11:46 PM
Kliptik's Avatar
Two-Time Mafiosi
Offline
Pocket PC: HTC Thunderbolt
Carrier: Verizon
Location: Austin, TX
 
Join Date: Feb 2009
Posts: 1,041
Reputation: 4790
Kliptik should be added to the payroll for their contributionsKliptik should be added to the payroll for their contributionsKliptik should be added to the payroll for their contributionsKliptik should be added to the payroll for their contributionsKliptik should be added to the payroll for their contributionsKliptik should be added to the payroll for their contributionsKliptik should be added to the payroll for their contributionsKliptik should be added to the payroll for their contributionsKliptik should be added to the payroll for their contributionsKliptik should be added to the payroll for their contributionsKliptik should be added to the payroll for their contributions
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Send a message via MSN to Kliptik
Re: Can I use .Net v4.0?

I haven't played around with VS2010 yet, but from what I've dug up, it doesn't support WM6 development. The WM6 OS uses a different version of the .NET framework called the .NET Compact Framework (v2.0 or v3.5), which isn't not supported in VS2010. The WM6 SDKs are free to download, but (again, from what I've read) VS2010 doesn't supprt them.

With MS going in the direction of Windows Phone 7, it seems they weren't too concerned with supporting WM6 development anymore. VS2008 Professional is available for a 90 day trial period if you want to get your feet wet in mobile development.

If I'm wrong in any of these, then anyone is free to post up!

Hope that helps!
__________________
  #3 (permalink)  
Old 06-14-2010, 11:48 PM
darren.wlsn1's Avatar
acs tester
Offline
Pocket PC: diamond/tp1/tp2/MoFo/touch 4g
Carrier: ppcgeeks/sprint
Location: pa
 
Join Date: May 2008
Posts: 24,870
Reputation: 51190
darren.wlsn1 can't get a higher reputation leveldarren.wlsn1 can't get a higher reputation leveldarren.wlsn1 can't get a higher reputation leveldarren.wlsn1 can't get a higher reputation leveldarren.wlsn1 can't get a higher reputation leveldarren.wlsn1 can't get a higher reputation leveldarren.wlsn1 can't get a higher reputation leveldarren.wlsn1 can't get a higher reputation leveldarren.wlsn1 can't get a higher reputation leveldarren.wlsn1 can't get a higher reputation leveldarren.wlsn1 can't get a higher reputation level
Mentioned: 14 Post(s)
Tagged: 0 Thread(s)
Send a message via AIM to darren.wlsn1 Send a message via MSN to darren.wlsn1 Send a message via Yahoo to darren.wlsn1 Send a message via Skype™ to darren.wlsn1
Re: Can I use .Net v4.0?

i have 3.7net on tp2
  #4 (permalink)  
Old 06-15-2010, 10:48 AM
Kliptik's Avatar
Two-Time Mafiosi
Offline
Pocket PC: HTC Thunderbolt
Carrier: Verizon
Location: Austin, TX
 
Join Date: Feb 2009
Posts: 1,041
Reputation: 4790
Kliptik should be added to the payroll for their contributionsKliptik should be added to the payroll for their contributionsKliptik should be added to the payroll for their contributionsKliptik should be added to the payroll for their contributionsKliptik should be added to the payroll for their contributionsKliptik should be added to the payroll for their contributionsKliptik should be added to the payroll for their contributionsKliptik should be added to the payroll for their contributionsKliptik should be added to the payroll for their contributionsKliptik should be added to the payroll for their contributionsKliptik should be added to the payroll for their contributions
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Send a message via MSN to Kliptik
Re: Can I use .Net v4.0?

Quote:
Originally Posted by darren.wlsn1 View Post
i have 3.7net on tp2
.NETCF right?
  #5 (permalink)  
Old 06-15-2010, 10:56 AM
darren.wlsn1's Avatar
acs tester
Offline
Pocket PC: diamond/tp1/tp2/MoFo/touch 4g
Carrier: ppcgeeks/sprint
Location: pa
 
Join Date: May 2008
Posts: 24,870
Reputation: 51190
darren.wlsn1 can't get a higher reputation leveldarren.wlsn1 can't get a higher reputation leveldarren.wlsn1 can't get a higher reputation leveldarren.wlsn1 can't get a higher reputation leveldarren.wlsn1 can't get a higher reputation leveldarren.wlsn1 can't get a higher reputation leveldarren.wlsn1 can't get a higher reputation leveldarren.wlsn1 can't get a higher reputation leveldarren.wlsn1 can't get a higher reputation leveldarren.wlsn1 can't get a higher reputation leveldarren.wlsn1 can't get a higher reputation level
Mentioned: 14 Post(s)
Tagged: 0 Thread(s)
Send a message via AIM to darren.wlsn1 Send a message via MSN to darren.wlsn1 Send a message via Yahoo to darren.wlsn1 Send a message via Skype™ to darren.wlsn1
Re: Can I use .Net v4.0?

Quote:
Originally Posted by Kliptik View Post
.NETCF right?
yep, posted the cab but m$ wanted to shoot me and sent ppcg a letter. lol
look at date i posted it. ill look for the link.
leaked net3.7 cab
This post has been thanked 1 times.
  #6 (permalink)  
Old 06-15-2010, 02:44 PM
Kliptik's Avatar
Two-Time Mafiosi
Offline
Pocket PC: HTC Thunderbolt
Carrier: Verizon
Location: Austin, TX
 
Join Date: Feb 2009
Posts: 1,041
Reputation: 4790
Kliptik should be added to the payroll for their contributionsKliptik should be added to the payroll for their contributionsKliptik should be added to the payroll for their contributionsKliptik should be added to the payroll for their contributionsKliptik should be added to the payroll for their contributionsKliptik should be added to the payroll for their contributionsKliptik should be added to the payroll for their contributionsKliptik should be added to the payroll for their contributionsKliptik should be added to the payroll for their contributionsKliptik should be added to the payroll for their contributionsKliptik should be added to the payroll for their contributions
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Send a message via MSN to Kliptik
Re: Can I use .Net v4.0?

thats craziness!
  #7 (permalink)  
Old 12-10-2010, 08:38 PM
Habibi's Avatar
Lurker
Offline
Pocket PC: HTC S730 , O2 XDA ii mini
Carrier: GSM-XL
Location: Indonesian
 
Join Date: Dec 2010
Posts: 3
Reputation: 0
Habibi is a n00b
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Send a message via Yahoo to Habibi
Re: Can I use .Net v4.0?

Quote:
Originally Posted by darren.wlsn1 View Post
i have 3.7net on tp2
if only it , too many outside ..!!!
__________________
I'll be glad to help but would prefer if my help appreciated >>> HBb <<< =D>=D>
Closed Thread

  PPCGeeks > Windows Mobile > Windows Mobile Development

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


All times are GMT -4. The time now is 10:42 AM.


Powered by vBulletin® ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
©2012 - PPCGeeks.com