PPCGeeks Forums HTC Arrive HTC HD2 HTC Thunderbolt HTC Touch Pro 2 HTC Evo 4G HTC Evo 3D Samsung Galaxy S II Motorola Droid X Apple iPhone Blackberry
Go Back   PPCGeeks > Windows Mobile > WM HTC Devices > HTC Titan

Notices



Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 06-22-2008, 04:03 PM
fuzzybabybunny's Avatar
PPCGeeks Regular
Offline
Pocket PC: HTC Touch Pro
Carrier: Sprint
 
Join Date: Jun 2008
Posts: 104
Reputation: 40
fuzzybabybunny is just getting started
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Red LED is all I get now...

I think I just bricked my phone.

Upgraded to NoChem's 5060 ROM yesterday and it was working fine for the entire day. I plugged the phone into the USB for the night. This morning I got a call, so I unplugged the phone and it suddenly turned completely off. I turned it back on, then it turned off again.

Now it won't turn back on. None of the buttons respond. Power + Camera + Reset doesn't do anything. Hard reset buttons don't do anything. Soft reset button doesn't do anything. When I plug it into USB the only thing that turns on is the Red LED next to the IE button. I've tried two different batteries. Tried it without the batteries. Left the battery out of the unplugged phone. Nothing seems to be doing anything.

I don't have insurance on the phone.
Reply With Quote
  #2 (permalink)  
Old 06-22-2008, 04:10 PM
EtherealRemnant's Avatar
*SCREEEEEECH*
Offline
Pocket PC: Touch Pro2
Carrier: Sprint
Location: Lakewood/Morrison CO
 
Join Date: Jan 2007
Posts: 2,044
Reputation: 589
EtherealRemnant knows their stuffEtherealRemnant knows their stuffEtherealRemnant knows their stuffEtherealRemnant knows their stuffEtherealRemnant knows their stuffEtherealRemnant knows their stuff
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Red LED is all I get now...

Check your battery connections are clean. Clean them with a bit of isopropyl (rubbing) alcohol on a qtip and let the phone sit for a few minutes. Then put the battery back in and try charging it again. If you still don't get it to work, you may very well have a brick and you're going to find out just how stupid it was to not pay the 7/mo for the insurance.

People really need to learn not to buy 550 dollar phones without the insurance...
__________________
***If I've helped you, don't forget to click the http://67.228.199.237/forum.ppcgeeks...ost_thanks.gif button!***

Comcast EXTREME:

http://www.speedtest.net/result/584166480.png
Reply With Quote
  #3 (permalink)  
Old 06-22-2008, 05:46 PM
chicubs3794's Avatar
PPCGeeks Regular
Offline
Pocket PC: Sprint Touch
Carrier: "PPCGeeks....I just use Sprint for calls"
Location: Disney World
 
Join Date: Feb 2008
Posts: 193
Reputation: 135
chicubs3794 is keeping up the good workchicubs3794 is keeping up the good work
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Red LED is all I get now...

or......try nueled
nueLED - configure/customize your LEDs...

EDIT: okay im stoooopid. yeah your mogul is screwed.
go to sprint and see if they can replace it,
__________________
Im not pawning for here, but if someone helped you out.....push their buttons.
Oh screw it just push mine and ill be happy.

Last edited by chicubs3794; 06-22-2008 at 06:02 PM.
Reply With Quote
  #4 (permalink)  
Old 06-22-2008, 05:48 PM
Webby's Avatar
Lurker
Offline
 
Join Date: May 2008
Posts: 11
Reputation: 5
Webby is a n00b
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Red LED is all I get now...

It's fried.
Reply With Quote
  #5 (permalink)  
Old 06-22-2008, 06:43 PM
cdigitaldetroit's Avatar
N00b
Offline
 
Join Date: Oct 2007
Posts: 46
Reputation: 50
cdigitaldetroit is becoming a great contributor
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Red LED is all I get now...

It sounds as if it didn't charge properly. When you plugged it in were you using the computers usb to charge, or were you using the actual charger? Which ever method you used, try using the other. Also try with both batteries. Keep in mind, it may take a while for the red light to change back to amber. You won't be able to use the phone while it has a red light either. Even if it's plugged in.

If this doesn't help, sign into my sprint, on sprints website, and add insurance. Wait a couple of days, and make a claim.
Reply With Quote
  #6 (permalink)  
Old 06-22-2008, 08:04 PM
holo's Avatar
Halfway to VIP Status
Offline
Pocket PC: touch pro
Carrier: sprint
Location: phoenix, az
 
Join Date: Sep 2007
Posts: 680
Reputation: 750
holo knows their stuffholo knows their stuffholo knows their stuffholo knows their stuffholo knows their stuffholo knows their stuffholo knows their stuff
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Red LED is all I get now...

Even if you don't have insurance you might be able to get it replaced since there is usually a 1 year warranty on phones. Take it to a sprint store and plead your case...

Don't try to add insurance after the fact, it won't work....
Reply With Quote
Reply

  PPCGeeks > Windows Mobile > WM HTC Devices > HTC Titan

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


All times are GMT -4. The time now is 07:49 PM.


Powered by vBulletin® ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
©2012 - PPCGeeks.com