PPCGeeks Forums HTC Arrive HTC HD2 HTC Thunderbolt HTC Touch Pro 2 HTC Evo 4G HTC Evo 3D Samsung Galaxy S II Motorola Droid X Apple iPhone Blackberry
Go Back   PPCGeeks > Windows Mobile > Windows Mobile Hacks/Tweaks

Notices



Closed Thread
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 12-13-2007, 08:21 PM
adma84's Avatar
Lurker
Offline
 
Join Date: Dec 2007
Posts: 5
Reputation: 0
adma84 is a n00b
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Unhappy HTML Tweak/Hack for WM6 Email (request)

OK read first before you just tell me to enable HTML in the settings , also I should caveat that I have WM6 Standard (Q9C)


Here is the deal, when I first set up my phone with my exchange server, it goes through, and sets up great.

I can read HTML emails...beautiful.

However, I have noticed, if I ever go back into activesync --> email --> settings, that HTML option becomes greyed out and I can never get it back unless I hard reset!

I have to go into those settings to add my digital certificate, so I am hoping someone knows of a hack where I can either ungrey that box OR just set HTML = 1 or something in the registry.

I found the following key:

HKEY_CU\software\microsoft\inbox\settings
ReadHTMLMail

But it is already set to 1, so I am guessing my problem lies somewhere else. Someone please help me!! Thank you in advance!
  #2 (permalink)  
Old 12-13-2007, 10:49 PM
TMB_XV6700's Avatar
Regular 'Geeker
Offline
Pocket PC: XV6700
Carrier: Verizon
Location: North Carolina
 
Join Date: Jan 2007
Posts: 485
Reputation: 25
TMB_XV6700 is just getting started
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
adma84,
I believe the graying-out of that box is set by the server, not by your device. Are you sure you're syncing to an Exchange 2007 server? Exchange 2003 and earlier don't support html.

BTW, I couldn't find that HKCU key on my WM6 Pro device.
__________________
XV6700 w/ Custom Apache WM6 Kitchen CE OS 5.2.1908 (Build 18508.0.7.0) - from Helmi_c and the guys at PPCGeeks.com
  #3 (permalink)  
Old 12-14-2007, 07:24 AM
adma84's Avatar
Lurker
Offline
Threadstarter
 
Join Date: Dec 2007
Posts: 5
Reputation: 0
adma84 is a n00b
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by TMB_XV6700 View Post
adma84,
I believe the graying-out of that box is set by the server, not by your device. Are you sure you're syncing to an Exchange 2007 server? Exchange 2003 and earlier don't support html.

BTW, I couldn't find that HKCU key on my WM6 Pro device.
Well here is the deal. My company's exchange server is Exchange 2003 (which I do know does not support HTML emails).

However, when I first sync to the server and do my settings, it lets me choose that option before it actually makes an attempt to connect to the server. My phone then syncs with the server, and all of my emails are in HTML...they look perfect! However, in order to set up my cert, I have to go back into the settings which then changes my HTML option to greyed out (which I am sure you are right, is mandated by the server).

But the fact is, I can get HTML to work, so I am hoping there is a registry key that I can force it back to try to get HTML. Thanks for any help!
  #4 (permalink)  
Old 12-14-2007, 08:48 AM
TMB_XV6700's Avatar
Regular 'Geeker
Offline
Pocket PC: XV6700
Carrier: Verizon
Location: North Carolina
 
Join Date: Jan 2007
Posts: 485
Reputation: 25
TMB_XV6700 is just getting started
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
So on initial sync you are actually receiving full html messages from an Exchange 2003 server(?). Sweet! Since my hosted Exchange provider has been taking its good ol' time transitioning from 2003 to 2007, I'm just as interested as you in getting this to work. It just seems to me that the solution will ultimately be server-side.
  #5 (permalink)  
Old 12-14-2007, 09:08 AM
ycats's Avatar
VIP Member
Offline
Pocket PC: Samsung Galaxy Note-2
Carrier: Sprint
Location: Nashville Tennessee
 
Join Date: Nov 2006
Posts: 1,572
Reputation: 447
ycats is becoming a PPCGeeks regularycats is becoming a PPCGeeks regularycats is becoming a PPCGeeks regularycats is becoming a PPCGeeks regularycats is becoming a PPCGeeks regular
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Activesync strips HTML email, that's what Microsoft told me. So unless they change this, we're out of luck. Although Exchange Server 2007 may be different. Mine at work is still 2003.
  #6 (permalink)  
Old 12-14-2007, 09:16 AM
adma84's Avatar
Lurker
Offline
Threadstarter
 
Join Date: Dec 2007
Posts: 5
Reputation: 0
adma84 is a n00b
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by TMB_XV6700 View Post
So on initial sync you are actually receiving full html messages from an Exchange 2003 server(?). Sweet! Since my hosted Exchange provider has been taking its good ol' time transitioning from 2003 to 2007, I'm just as interested as you in getting this to work. It just seems to me that the solution will ultimately be server-side.
Not just initial sync. I get it every sync until I go to install my cert. So while intuitively I would think the server should be the one to strip things away, I definitely can get HTML emails.
  #7 (permalink)  
Old 12-14-2007, 09:22 AM
ycats's Avatar
VIP Member
Offline
Pocket PC: Samsung Galaxy Note-2
Carrier: Sprint
Location: Nashville Tennessee
 
Join Date: Nov 2006
Posts: 1,572
Reputation: 447
ycats is becoming a PPCGeeks regularycats is becoming a PPCGeeks regularycats is becoming a PPCGeeks regularycats is becoming a PPCGeeks regularycats is becoming a PPCGeeks regular
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
The only email account I have sync'd with the server is Outlook...........all others I download manually (Sprint, Yahoo!, Gmail, etc.) and these others come through in HTML format.
  #8 (permalink)  
Old 12-14-2007, 09:55 AM
adma84's Avatar
Lurker
Offline
Threadstarter
 
Join Date: Dec 2007
Posts: 5
Reputation: 0
adma84 is a n00b
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Yeah...The only thing I sync is my exchange server...with push
Closed Thread

  PPCGeeks > Windows Mobile > Windows Mobile Hacks/Tweaks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


All times are GMT -4. The time now is 02:24 AM.


Powered by vBulletin® ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
©2012 - PPCGeeks.com