PPCGeeks Forums HTC Arrive HTC HD2 HTC Thunderbolt HTC Touch Pro 2 HTC Evo 4G HTC Evo 3D Samsung Galaxy S II Motorola Droid X Apple iPhone Blackberry
Go Back   PPCGeeks > Windows Mobile > WM Other Manufacturers > LG Fathom

Notices



Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 04-17-2012, 11:38 AM
hero121's Avatar
PPCGeeks Regular
Offline
Pocket PC: LG Fathom verizon
Carrier: Airtel
 
Join Date: Aug 2011
Posts: 115
Reputation: 25
hero121 is just getting started
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Automatic add 011 prefix in place of + sign in contact number in cdma mode ?

Dear All,

I am using both cdma reliance(india) & GSM in my LG fathom. But there is problem in dialing. All my contact are with pre fix code like +91xxxxxxxxxx
When I dial (CDMA network) with contacts name its automatic add a prefix code of 01191xxxxxxxxxx. That means its add 011 in place of +.and not working.
When I use with assisted dialing after setting it to India its look like 0xxxxxxxxxx. and it is working, but in sms sending the assisted system is not working and its add 011 before the number.so i can not send sms without editing my contact number.

Here I want Expert's help in this regard, is any way not to use assisted dialing in cdma mode ? is any registry tricks or advice ? because there is no any problem in GSM mode with all my contacts starts with +sign code. Its problem in only cdma mode.

without your help I have to change in my all contacts manually. all incoming calls are comes through with +91 as I am in India. even in cdma all incoming calls are coming with prefix +91 and ten digit number. but unable to call with +91 prefix.in dialed number.

Any help in this ?

Last edited by hero121; 04-17-2012 at 11:41 AM.
Reply With Quote
  #2 (permalink)  
Old 04-19-2012, 01:43 AM
headhair's Avatar
PPCGeeks Regular
Offline
Pocket PC: LG Fathom
Carrier: Aircel
 
Join Date: Dec 2011
Posts: 75
Reputation: 5
headhair is a n00b
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Automatic add 011 prefix in place of + sign in contact number in cdma mode ?

Dear Hero121,

Quote:
Here I want Expert's help in this regard, is any way not to use assisted dialing in cdma mode ?
You can very well disable assisted dialing using Phone settings->CDMA Services->Assisted Dialing->get settings->Untick "enable assisted dialing".
You can call any number with +91 prefix.

Also you can make India as Default Region for Assisted Dialing.
[HKEY_LOCAL_MACHINE\ControlPanel\Phone\AssistedDial ing]
change the value of "DefaultRefRegion" to "IN"

Also you can delete all the values in the assisting Dialing Field & Restart the phone.
No extra number will be added, while you dial. You need not change your number.

Quote:
n sms sending the assisted system is not working and its add 011 before the number.so i can not send sms without editing my contact number.
As far as SMS is concerned, I didn't try to send SMS using CDMA as I usually send SMS using GSM. In CDMA network SMS doesnot allow any extra characters like + in contact number. If present, it will throw "Cause Code 32880 Unknown Error". There must be some solution to this.

I will look into this problem.
Reply With Quote
  #3 (permalink)  
Old 04-19-2012, 08:21 AM
hero121's Avatar
PPCGeeks Regular
Offline
Pocket PC: LG Fathom verizon
Carrier: Airtel
Threadstarter
 
Join Date: Aug 2011
Posts: 115
Reputation: 25
hero121 is just getting started
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Re: Automatic add 011 prefix in place of + sign in contact number in cdma mode ?

Quote:
Originally Posted by headhair View Post
Dear Hero121,



You can very well disable assisted dialing using Phone settings->CDMA Services->Assisted Dialing->get settings->Untick "enable assisted dialing".
You can call any number with +91 prefix.

Also you can make India as Default Region for Assisted Dialing.
[HKEY_LOCAL_MACHINE\ControlPanel\Phone\AssistedDial ing]
change the value of "DefaultRefRegion" to "IN"

Also you can delete all the values in the assisting Dialing Field & Restart the phone.
No extra number will be added, while you dial. You need not change your number.


As far as SMS is concerned, I didn't try to send SMS using CDMA as I usually send SMS using GSM. In CDMA network SMS doesnot allow any extra characters like + in contact number. If present, it will throw "Cause Code 32880 Unknown Error". There must be some solution to this.

I will look into this problem.
Dear headhair

Sir,
This is not an issue to disable assisted dialing, It is an issue dial with +91 without activating assisted dialing.
It is ok we can make DefaultRefRegion as India but again after that it is necessary to activate by check assisted dialing to work dial with +91 Pefix numbers otherwise not working.
Another you have mentioned delete all the fields and leave it blank. But it never stay blank.
I am unable to dial without assisted dialing whenever my contacts starts with +91, You all ready know that I am Indian an most of all my contacts are with +91 prefix.
If I delete all the +91 from my contact then I can able to dial directly without activating Assisted dialing.
without assisted dialing its always add 011 in place of symbol " + "
after making DefaultRefRegion to IN also.

Please look in what I want to say,

Thanks
Reply With Quote
  #4 (permalink)  
Old 04-20-2012, 01:49 AM
headhair's Avatar
PPCGeeks Regular
Offline
Pocket PC: LG Fathom
Carrier: Aircel
 
Join Date: Dec 2011
Posts: 75
Reputation: 5
headhair is a n00b
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Automatic add 011 prefix in place of + sign in contact number in cdma mode ?

Sorry Hero121,
I don't understand your problem.

Do you mean that after deactivating Assisted Dialing you couldn't dial
contacts with +91 prefix? In my case, I have permanently deactivated Assisted Dialing. While I dial contact with +91, it automatically changed to 00 91.


Could you please PM me the following Registry part from Your Mobile?
HKEY_LOCAL_MACHINE\ControlPanel\Phone\AssistedDial ing
Reply With Quote
  #5 (permalink)  
Old 04-20-2012, 03:19 AM
hero121's Avatar
PPCGeeks Regular
Offline
Pocket PC: LG Fathom verizon
Carrier: Airtel
Threadstarter
 
Join Date: Aug 2011
Posts: 115
Reputation: 25
hero121 is just getting started
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Re: Automatic add 011 prefix in place of + sign in contact number in cdma mode ?

Quote:
Do you mean that after deactivating Assisted Dialing you couldn't dial
contacts with +91 prefix?


Could you please PM me the following Registry part from Your Mobile?
HKEY_LOCAL_MACHINE\ControlPanel\Phone\AssistedDial ing
Yes Sir , I could not dial after deactivating Assisted dialing to a contacts with +91 prefix.

With assisted dialing there is no problem.

For your reference I am attaching my .rgu file of my rom. in that you will easily find the string value HKEY_LOCAL_MACHINE\ControlPanel\Phone\AssistedDial ing

Again thanks

Last edited by hero121; 04-20-2012 at 03:33 AM.
Reply With Quote
  #6 (permalink)  
Old 04-20-2012, 05:52 AM
headhair's Avatar
PPCGeeks Regular
Offline
Pocket PC: LG Fathom
Carrier: Aircel
 
Join Date: Dec 2011
Posts: 75
Reputation: 5
headhair is a n00b
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Automatic add 011 prefix in place of + sign in contact number in cdma mode ?

Dear Hero121,

After looking Registry, it seems the default values are for US in Assisted Dialing
Quote:
[ H K E Y _ L O C A L _ M A C H I N E \ C o n t r o l P a n e l \ P h o n e \ A s s i s t e d D i a l i n g ]

" E n a b l e d " = d w o r d : 0

" C u r r e n t R e g i o n " = " U S "

" D e f a u l t R e f R e g i o n " = " U S "

" C u r r e n t A r e a C o d e " = " 0 0 0 "


[ H K E Y _ C U R R E N T _ U S E R \ C o n t r o l P a n e l \ P h o n e \ A s s i s t e d D i a l i n g ]

" A c t i v e " = d w o r d : 0

" R e f e r e n c e R e g i o n " = " U S "

" C o u n t r y C o d e " = " 1 "

" I D D " = " 0 1 1 "

" N D D " = " 1 "

" A r e a C o d e " = " 0 0 0 "

" N a t i o n a l L e n g t h " = d w o r d : 0 A
Please change the values as below & Restart your phone & try.
Quote:
[HKEY_LOCAL_MACHINE\ControlPanel\Phone\AssistedDial ing]
"CurrentRegion"="IN"
"DefaultRefRegion"="IN"
"CurrentAreaCode"="000"
"Enabled"=dword:00000000

[HKEY_CURRENT_USER\ControlPanel\Phone\AssistedDiali ng]
"IDD"="00"
"CountryCode"="91"
"NDD"="0"
"ReferenceRegion"="IN"
"AreaCode"="xxx" (Your first 3 digits of your CDMA Mobile Number)
"Possibility"=dword:00000000
"NationalLength"=dword:0000000A
"Active"=dword:00000000

[HKEY_LOCAL_MACHINE\ControlPanel\Phone\AssistedDial ing\Regions\IN]
"AreaCode"="xxx" (Your first 3 digits of your CDMA Mobile Number)
"NationalLength"=dword:0000000A
"NDD"="0"
"IDD"="00"
"CountryCode"="91"
"Name"="India"
Please try & reply

Last edited by headhair; 04-20-2012 at 06:00 AM.
Reply With Quote
  #7 (permalink)  
Old 04-21-2012, 03:04 AM
hero121's Avatar
PPCGeeks Regular
Offline
Pocket PC: LG Fathom verizon
Carrier: Airtel
Threadstarter
 
Join Date: Aug 2011
Posts: 115
Reputation: 25
hero121 is just getting started
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Re: Automatic add 011 prefix in place of + sign in contact number in cdma mode ?

Quote:
Originally Posted by headhair View Post
Dear Hero121,

After looking Registry, it seems the default values are for US in Assisted Dialing


Please change the values as below & Restart your phone & try.


Please try & reply
Dear headhair

Sir,
I have changed all as advised by you, But it is not working when I disabled Assisted dialing in phone menu.
Sir,
Please care what I want to say, 1-you have suggested all edits in ASSISTED DIALING.

Here my question is If it is (assisted dialing) not activated , how it will work ? and what will be the meaning to edit in assisted dialing registry.

When I go to phone/menu/assisted dialing and check enabled assisted dialing,
Its worked fine.
But without enabling assisted dialing it does not work.

Please check again in your set regarding assisted dialing
Is it enabled or not ?
Is it enable in hidden mode ?

In my set upon activation of assisted dialing, it clearly shows written as assisted dialing on left upper corner of screen while in phone mode.

I want not to use assisted dialing in any way to dial a contact with +91 prefix
With assisted dialing I could easily dial any number with +91 prefix

Any way I have tried all your suggestion, but it is not working while my assisted dialing mode is deactivated.
Thanks

I am attaching new reg. key below:

Last edited by hero121; 04-21-2012 at 03:20 AM.
Reply With Quote
  #8 (permalink)  
Old 04-21-2012, 06:35 AM
headhair's Avatar
PPCGeeks Regular
Offline
Pocket PC: LG Fathom
Carrier: Aircel
 
Join Date: Dec 2011
Posts: 75
Reputation: 5
headhair is a n00b
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Automatic add 011 prefix in place of + sign in contact number in cdma mode ?

Sorry Hero121,
I am very sure that Assisted Dialing is NOT enabled in my phone. But still I could call numbers with +91. It is simply replaced with 00 91.

Quote:
Is it enable in hidden mode ?
What do you mean by hidden mode?

After comparing registry values I find only one key extra in my phone.
[HKEY_LOCAL_MACHINE\ControlPanel\Phone\AssistedDial ing]
"CurrentGSMMCC"=dword:00000194

I don't know this will help you.
Reply With Quote
  #9 (permalink)  
Old 04-21-2012, 06:46 AM
headhair's Avatar
PPCGeeks Regular
Offline
Pocket PC: LG Fathom
Carrier: Aircel
 
Join Date: Dec 2011
Posts: 75
Reputation: 5
headhair is a n00b
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Automatic add 011 prefix in place of + sign in contact number in cdma mode ?

Dear Hero121,

Start->setting->System->Regional Setting->Region->
Select "English (united Kingdom)" ->
Restart the Phone.

Now dial (without enabling Assisted Dialing). Your contact + will be replaced by 00. And
you need not change + sign.
Reply With Quote
  #10 (permalink)  
Old 04-21-2012, 08:50 AM
hero121's Avatar
PPCGeeks Regular
Offline
Pocket PC: LG Fathom verizon
Carrier: Airtel
Threadstarter
 
Join Date: Aug 2011
Posts: 115
Reputation: 25
hero121 is just getting started
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Re: Automatic add 011 prefix in place of + sign in contact number in cdma mode ?

Quote:
Originally Posted by headhair View Post
Dear Hero121,

Start->setting->System->Regional Setting->Region->
Select "English (united Kingdom)" ->
Restart the Phone.

Now dial (without enabling Assisted Dialing). Your contact + will be replaced by 00. And
you need not change + sign.
Dear headhair

First A lot of thanks to you for finding the root cause of my problem. It is now 100 % working without enabling assisted dialing.
After changing region to English(United kingdom) It's working without the help of assisted dialing.

I was sure it should not be the problem of assisted dialing, because without enabling it, it did not had any use. but I was helpless to find the solution.
[Now dialing a number with + sign is being replaced by 00]
It is really a expert's help like you !
Thanks and a lot of thanks, because I could not give you more, from here.

Last edited by hero121; 04-21-2012 at 09:02 AM.
Reply With Quote
Reply

  PPCGeeks > Windows Mobile > WM Other Manufacturers > LG Fathom

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


All times are GMT -4. The time now is 10:37 PM.


Powered by vBulletin® ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
©2012 - PPCGeeks.com