PPCGeeks Forums HTC Arrive HTC HD2 HTC Thunderbolt HTC Touch Pro 2 HTC Evo 4G HTC Evo 3D Samsung Galaxy S II Motorola Droid X Apple iPhone Blackberry
Go Back   PPCGeeks > Windows Mobile > WM HTC Devices > HTC Touch Pro

Notices



Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 03-17-2009, 08:32 PM
isevilla's Avatar
N00b
Offline
Pocket PC: Treo Pro
Carrier: Sprint
Location: IL
 
Join Date: Apr 2008
Posts: 35
Reputation: 10
isevilla is a n00b
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Angry WIFI Not Connecting to home network

I am trying to connect my Sprint Touch Pro to my home network. The router is a linksys dual band N router and theyre a few computers connected to both the 2.4 and 5.0 networks. Before getting this router the touch would connect to the home network which was hidden and used a shorter wep key just fine. The router is still hidden but now uses wep 104 encryption.

I have setup the phone pretty much the same way it was before with the exception of a longer key. All other computers and game systems connect just fine.

Any help or ideas?

Thanks in advance,

Is.
Reply With Quote
  #2 (permalink)  
Old 03-17-2009, 09:11 PM
kennyidaho's Avatar
PPCGeeks Regular
Offline
Pocket PC: Touch Pro
Carrier: Sprint
 
Join Date: Feb 2008
Posts: 100
Reputation: 95
kennyidaho is becoming a great contributor
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: WIFI Not Connecting to home network

You don't have any mac address filtering going on do you? On the touch pro did you make sure to deleting the old network and then adding the new one? You can delete the network under Settings > connections > Wi-Fi > hold down your stylus on the network and pick remove.

Also why are you still using WEP? Just to let you know it's not entirely secure also hiding your network really only serves to add a layer of difficulty that you have to deal with when setting up your devices. The rest of the world can and still does see hidden networks.

Last edited by kennyidaho; 03-17-2009 at 09:27 PM.
Reply With Quote
  #3 (permalink)  
Old 03-17-2009, 11:08 PM
isevilla's Avatar
N00b
Offline
Pocket PC: Treo Pro
Carrier: Sprint
Threadstarter
Location: IL
 
Join Date: Apr 2008
Posts: 35
Reputation: 10
isevilla is a n00b
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: WIFI Not Connecting to home network

Quote:
Originally Posted by kennyidaho View Post
You don't have any mac address filtering going on do you? On the touch pro did you make sure to deleting the old network and then adding the new one? You can delete the network under Settings > connections > Wi-Fi > hold down your stylus on the network and pick remove.

Also why are you still using WEP? Just to let you know it's not entirely secure also hiding your network really only serves to add a layer of difficulty that you have to deal with when setting up your devices. The rest of the world can and still does see hidden networks.
I just did the mac filtering again but when I was trying to connect it was disabled. I did find the mac address of the phone and added it to the list on the router and it still didnt connect. So didnt connect with or without the mac filtering.

Yes the old network was deleted. New one was created.

Used Wep so that it would be easier for the kids to remember the key as their laptops are not on the N network like mine are. My pc and laptop are on the N network with wpa2 i believe enabled.

As far as hiding the network I havent had any trouble connecting the other devices except for the touch.
Reply With Quote
  #4 (permalink)  
Old 03-17-2009, 11:40 PM
Asphyx's Avatar
Halfway to VIP Status
Offline
Pocket PC: HTC TouchPro (VZW)
Carrier: Verizon
Location: Las Vegas
 
Join Date: Dec 2007
Posts: 504
Reputation: 425
Asphyx is becoming a PPCGeeks regularAsphyx is becoming a PPCGeeks regularAsphyx is becoming a PPCGeeks regularAsphyx is becoming a PPCGeeks regularAsphyx is becoming a PPCGeeks regular
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: WIFI Not Connecting to home network

First off don't use WEP...
It's insecure and you can't easily use passwords as they are nine miles long depending on the software trying to use it...

Switch the router to WPA2-Personal....
Much easier to maintain and way more secure than WEP.

You don't really need macfiltering unless you want to deny some computers on your network from having access to the router. It doesn't really make your computer any more secure because it is so easy to clone and spoof a mac address if your trying to hack.

With Linksys also when you disable the filter you might have to do a cold reboot (unplug wait 30 secs then power up again.)
You want to re-enable again after you get your connection issues solved thats fine.
Reply With Quote
  #5 (permalink)  
Old 03-18-2009, 12:15 AM
santod's Avatar
"MODS"
Offline
Pocket PC: Touch Pro 2/Thunderbolt
Carrier: Verizon Wireless
Location: NorCal
 
Join Date: Sep 2008
Posts: 3,984
Reputation: 22765
santod can't get a higher reputation levelsantod can't get a higher reputation levelsantod can't get a higher reputation levelsantod can't get a higher reputation levelsantod can't get a higher reputation levelsantod can't get a higher reputation levelsantod can't get a higher reputation levelsantod can't get a higher reputation levelsantod can't get a higher reputation levelsantod can't get a higher reputation levelsantod can't get a higher reputation level
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: WIFI Not Connecting to home network

Also, you might try setting it for Work Network instead of any other setting for your WLAN. That was what worked for me with my Touch Pro and Linksys N router.

Last edited by santod; 03-18-2009 at 04:24 AM.
Reply With Quote
  #6 (permalink)  
Old 03-18-2009, 01:19 AM
kennyidaho's Avatar
PPCGeeks Regular
Offline
Pocket PC: Touch Pro
Carrier: Sprint
 
Join Date: Feb 2008
Posts: 100
Reputation: 95
kennyidaho is becoming a great contributor
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: WIFI Not Connecting to home network

Quote:
Originally Posted by isevilla View Post
I just did the mac filtering again but when I was trying to connect it was disabled. I did find the mac address of the phone and added it to the list on the router and it still didnt connect. So didnt connect with or without the mac filtering.

Yes the old network was deleted. New one was created.

Used Wep so that it would be easier for the kids to remember the key as their laptops are not on the N network like mine are. My pc and laptop are on the N network with wpa2 i believe enabled.

As far as hiding the network I havent had any trouble connecting the other devices except for the touch.
Okay you have me utterly confused. Perhaps this is something this router does; but two wireless networks and two security configurations from one router? Typically the router will accept a/b/g/n clients and communicate with them on whatever standard they support. Maybe I am getting old.

MAC filtering is a bad idea. With mac filtering all your doing is providing any would be hackers a nice list of mac addresses to spoof. Which makes network intrusion detection on your part harder because all you'll see is a familiar MAC address, but in fact it's the pimple faced kid next door spoofing the MAC address of your kids laptop.

Hidden networks are a false security. I can log into my router and it will show me all these "hidden" networks. With a couple keystrokes on my computer I can easily decloak any hidden SSID's. It's pointless and leads to bad security judgments because one assumes they are safe because they are hidden. Hidden networks also cause a host of performance issues.

WEP keys are normally long strings that are hard to remember and easy to crack, same pimple faced kid next door would be able to crack your WEP key in a matter of moments. WPA is much better, it's much more secure and plus you can use words that humans read.

Honestly at this point my best suggestion is unhide your SSID, move all your encryption to WPA or WPA2. Stop filtering MAC addresses, and stop restricting certain devices to certain 802.11 standards. What you'll end up with is a possibly a better performing network, that is more secure and I willing to bet your touch will work.

I know it's not what you want to hear.

Last edited by kennyidaho; 03-18-2009 at 01:24 AM.
Reply With Quote
  #7 (permalink)  
Old 03-19-2009, 01:33 PM
isevilla's Avatar
N00b
Offline
Pocket PC: Treo Pro
Carrier: Sprint
Threadstarter
Location: IL
 
Join Date: Apr 2008
Posts: 35
Reputation: 10
isevilla is a n00b
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: WIFI Not Connecting to home network

Quote:
Originally Posted by kennyidaho View Post
Okay you have me utterly confused. Perhaps this is something this router does; but two wireless networks and two security configurations from one router? Typically the router will accept a/b/g/n clients and communicate with them on whatever standard they support. Maybe I am getting old.
This particular router has dual bands which is actually two networks in one router if you want to use that way. I have our non N laptops connected to the 2.4 ghz mixed mode network and the N card machines connected to the 5 ghz N only mode.

Quote:
Originally Posted by kennyidaho View Post
MAC filtering is a bad idea. With mac filtering all your doing is [providing any would be hackers a nice list of mac addresses to spoof. Which makes network intrusion detection on your part harder because all you'll see is a familiar MAC address, but in fact it's the pimple faced kid next door spoofing the MAC address of your kids laptop.
Very good point... I have disabled the mac address filtering altogether.

Quote:
Originally Posted by kennyidaho View Post
Hidden networks are a false security. I can log into my router and it will show me all these "hidden" networks. With a couple keystrokes on my computer I can easily decloak any hidden SSID's. It's pointless and leads to bad security judgments because one assumes they are safe because they are hidden. Hidden networks also cause a host of performance issues.
This has always been a real pain in the butt when a pc lost its connection and wouldnt connect again and I would have to go through hoops to get it back online. I have disabled this as well.

Quote:
Originally Posted by kennyidaho View Post
WEP keys are normally long strings that are hard to remember and easy to crack, same pimple faced kid next door would be able to crack your WEP key in a matter of moments. WPA is much better, it's much more secure and plus you can use words that humans read.
Currently the 2.4 ghz mixed network has wep and that is because we have 1 machine that we lost our product key for and we cant get anything other than wep to work on it at this time (long story). The N network has wpa2 in place.

And funny that you mention that pimple faced kid scenario because I noticed last night that we had someone else on our network. We have a ps3 on our network and im not sure if they got in that way or not but anyway I blocked the pc.

Quote:
Originally Posted by kennyidaho View Post
Honestly at this point my best suggestion is unhide your SSID, move all your encryption to WPA or WPA2. Stop filtering MAC addresses, and stop restricting certain devices to certain 802.11 standards. What you'll end up with is a possibly a better performing network, that is more secure and I willing to bet your touch will work.
I have done all the above and after doing so my touch pro connected immediately to the network. It totally doesnt like connecting to hidden networks for some reason because as soon as I allowed the ssid broadcast it connected.

Quote:
Originally Posted by kennyidaho View Post
I know it's not what you want to hear.
Im always open to suggestions as I would not have come here to ask for them in the first place

Thank you for your help and suggestions!
Reply With Quote
  #8 (permalink)  
Old 03-19-2009, 01:34 PM
isevilla's Avatar
N00b
Offline
Pocket PC: Treo Pro
Carrier: Sprint
Threadstarter
Location: IL
 
Join Date: Apr 2008
Posts: 35
Reputation: 10
isevilla is a n00b
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: WIFI Not Connecting to home network

Thank you everyone who responded for your help!
Reply With Quote
  #9 (permalink)  
Old 03-19-2009, 02:32 PM
kennyidaho's Avatar
PPCGeeks Regular
Offline
Pocket PC: Touch Pro
Carrier: Sprint
 
Join Date: Feb 2008
Posts: 100
Reputation: 95
kennyidaho is becoming a great contributor
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: WIFI Not Connecting to home network

I finally got caught up on these dual band access points and it's pretty cool stuff. Just now I feel a little behind. I guess it's impossible to keep up anymore.

I am glad you got things working. As far as the PS3, on my network the PS3 used to always show up as * or it was just blank. I assigned a static IP address to it and my router lets me adjust the name that displays in the log.
Reply With Quote
Reply

  PPCGeeks > Windows Mobile > WM HTC Devices > HTC Touch Pro

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


All times are GMT -4. The time now is 09:06 AM.


Powered by vBulletin® ©2000 - 2020, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
©2012 - PPCGeeks.com