PPCGeeks Forums HTC Arrive HTC HD2 HTC Thunderbolt HTC Touch Pro 2 HTC Evo 4G HTC Evo 3D Samsung Galaxy S II Motorola Droid X Apple iPhone Blackberry
Go Back   PPCGeeks > Windows Mobile > WM HTC Devices > HTC Titan

Notices



Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 11-17-2007, 10:23 AM
AJerman's Avatar
N00b
Offline
 
Join Date: Aug 2007
Posts: 26
Reputation: 0
AJerman is a n00b
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Battery won't charge?!

So last night, my battery is dead and I'm still on the latest firmware because I haven't had a chance to do a hard-reset while flashing the older firmware and then going through the hassle of restoring everything. So being that that's the case, I can't tell if it's just locked up yet again like it does at least 5 times a day, or if the battery was dead (don't remember if the LED was flashing).

Either way, I do a reset and plug it in. It boots up and won't start charging. It says low battery and turns off and still won't start charging. I plug the charger into something else to make sure it works and it works fine. I try plugging the phone into a mini-USB hooked into my computer, nothing.

So is this how it ends? This has got to be the most horrible phone I've ever dealt with, while at the same time being the best. It was my first smartphone and I love the touch screen and software and all, but man does the Mogul suck.

Does anyone have any ideas before I sit on the phone for hours waiting to talk to someone intelligent at Sprint?
Reply With Quote
  #2 (permalink)  
Old 11-17-2007, 10:31 AM
bmx045's Avatar
N00b
Offline
 
Join Date: Oct 2007
Posts: 30
Reputation: 0
bmx045 is a n00b
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Maybe the usb port on your phone is faulty, seeing that the computer doesn't recognize it, and the phone won't rezognize the charger. Take the battery out and charge it in the cradle for the time being. Meanwhile, take the phone with usb cable to another computer and listen for the "ding" new hardware found, if nothing, then I'd be suspicious of a faulty usb port...it happens....
__________________
Verizon XV6700
Helmi's WM6 Kitchen
Radio 1.43.00
1gb MiniSD
Reply With Quote
  #3 (permalink)  
Old 11-17-2007, 10:39 AM
AJerman's Avatar
N00b
Offline
Threadstarter
 
Join Date: Aug 2007
Posts: 26
Reputation: 0
AJerman is a n00b
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by bmx045 View Post
Maybe the usb port on your phone is faulty, seeing that the computer doesn't recognize it, and the phone won't rezognize the charger. Take the battery out and charge it in the cradle for the time being. Meanwhile, take the phone with usb cable to another computer and listen for the "ding" new hardware found, if nothing, then I'd be suspicious of a faulty usb port...it happens....
I don't have a cradle for the battery though, so I have no way of charging it.

It seems like EVERYTHING happens to this phone.
Reply With Quote
  #4 (permalink)  
Old 11-17-2007, 10:39 AM
nuguy's Avatar
Oldguy
Offline
Pocket PC: Moto DROID
Carrier: vzw
Location: Between Chicago an Milwaukee (Libertyville, IL)
 
Join Date: Feb 2007
Posts: 1,313
Reputation: 625
nuguy knows their stuffnuguy knows their stuffnuguy knows their stuffnuguy knows their stuffnuguy knows their stuffnuguy knows their stuff
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Don't plug it in while it's booting, that uses too much juice, and it thinks the cable is the battery.

either take the battery out and charge the bat in the cradle (best option) or wait till it boots fully, and suspend it, THEN plug it in...
Reply With Quote
  #5 (permalink)  
Old 11-17-2007, 10:42 AM
nuguy's Avatar
Oldguy
Offline
Pocket PC: Moto DROID
Carrier: vzw
Location: Between Chicago an Milwaukee (Libertyville, IL)
 
Join Date: Feb 2007
Posts: 1,313
Reputation: 625
nuguy knows their stuffnuguy knows their stuffnuguy knows their stuffnuguy knows their stuffnuguy knows their stuffnuguy knows their stuff
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
bmx you beat me to the punch...
Reply With Quote
  #6 (permalink)  
Old 11-17-2007, 12:44 PM
AJerman's Avatar
N00b
Offline
Threadstarter
 
Join Date: Aug 2007
Posts: 26
Reputation: 0
AJerman is a n00b
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by nuguy View Post
Don't plug it in while it's booting, that uses too much juice, and it thinks the cable is the battery.

either take the battery out and charge the bat in the cradle (best option) or wait till it boots fully, and suspend it, THEN plug it in...
If that were the case (it thought the cable was the battery) at least it would run. I've tried plugging it in at all different times. I suspect, as bmx said, that the USB port has just gone out. The thing that annoys me about that is that it wasn't being problematic at all before, it was yanked by the cord or anything, it just randomly stops working one day. I'm going to have to call Sprint and they better not send me another Mogul. As much as I like this phone, I'm done with it. I'll see if they'll send me a Touch like they've been doing a bunch of other people.
Reply With Quote
Reply

  PPCGeeks > Windows Mobile > WM HTC Devices > HTC Titan

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


All times are GMT -4. The time now is 05:31 PM.


Powered by vBulletin® ©2000 - 2020, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
©2012 - PPCGeeks.com