PPCGeeks Forums HTC Arrive HTC HD2 HTC Thunderbolt HTC Touch Pro 2 HTC Evo 4G HTC Evo 3D Samsung Galaxy S II Motorola Droid X Apple iPhone Blackberry
Go Back   PPCGeeks > Windows Mobile > WM HTC Devices > HTC Imagio

Notices



Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 12-11-2009, 07:03 PM
jeff_roey's Avatar
PPCGeeks Regular
Offline
Pocket PC: HTC Imagio
Carrier: Verizon
 
Join Date: Oct 2009
Posts: 99
Reputation: 245
jeff_roey is keeping up the good workjeff_roey is keeping up the good workjeff_roey is keeping up the good work
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Question Bluetooth Connection Slows Everything Down

Having a problem with my Imagio when connecting to my vehicle's bluetooth: the phone just flat out slows to a crawl.

As soon as I pair with my vehicle (a 2009 Chevy Equinox) the phone's responsiveness falls way off - can't really do anything with it at all. If I break the pair - usually have to use the vehicle's UI to do this since I can't navigate to the COMM Manager - responsiveness comes right back immediately.

I've looked through the forums and found a similar thread in the TP2 section with no resolution. Anyone else dealing with this and/or find a non-hard-reset solution???
Reply With Quote
  #2 (permalink)  
Old 12-15-2009, 05:38 PM
jeff_roey's Avatar
PPCGeeks Regular
Offline
Pocket PC: HTC Imagio
Carrier: Verizon
Threadstarter
 
Join Date: Oct 2009
Posts: 99
Reputation: 245
jeff_roey is keeping up the good workjeff_roey is keeping up the good workjeff_roey is keeping up the good work
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Exclamation FIXED: Bluetooth Connection Slows Everything Down

Warning: this could be the dumbest thing you've read about the WIDCOMM stack in a long timme . . . but it solved my problem.

I figured out that my pim.vol file was what was causing my BT to slow my phone to a crawl when I established a connection with my Chevy Equinox.If you find yourself addressing a similar issue, I suggest you add your pim.vol to your list of things to troubleshoot.


Long story short, after having perfectly functioning BT since the time I received my Imagio, sometime over the past few weeks it went south - establishing an in-car BT just killed the phone's response. I couldn't make a call let alone open a gps or any other app. I naturally thought it was something I installed so after hours of uninstalling and re-installing, a bucket full of hard resets, etc, I figured out that my pim.vol was the root of all evil - the version I was restoring was somehow interfering the my BT connection.

I know, I know . . . but here's the thing: the way I narrowed it down was by doing an in-car hard reset and restoration (I'm officially coining that phrase ). I sat in the car in the driveway and re-installed my apps in groups of 2 and 3, pairing and breaking the pair to the vehicle in between. After successfully coming through all of my apps this way the device continued to work perfectly. I thought I somehow licked it with only restoring my pim.vol left - normally, that would be one of the first things I'd restore - and sure enough after I did that the lag returned. I reverted to an older, back-up copy of my pim, re-paired and the lag disappeared. Flip-flopped between current and old pim a few times for confirmation, and it didn't take long to convince me it was the source of the problem.

I cant begin to imagine why. The "corrupted" pim functioned perfectly well in every other respect (even with other BT earbuds) - just sapped my phone when connected to my in-car BT. Just for reference, my pim is about 2.8 mb - don't know if that has anything to do with it.

Let me know if you get desperate enough to try a similar approach and if it works for you.
Reply With Quote
  #3 (permalink)  
Old 01-19-2010, 01:37 PM
dmitrynt's Avatar
Lurker
Offline
Pocket PC: HTC Imagio (used to have vx6800)
Carrier: Verizon
Location: New York
 
Join Date: Jan 2008
Posts: 11
Reputation: 0
dmitrynt is a n00b
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Send a message via Yahoo to dmitrynt Send a message via Skype™ to dmitrynt
Question Re: Bluetooth Connection Slows Everything Down

i got HTC Imagio and i got same problem with slow phone once it gets BT connection in my car.

I did not understand the workaround. Do i have to remove pim.vol and reload all my contacts?
Reply With Quote
  #4 (permalink)  
Old 01-19-2010, 01:56 PM
jeff_roey's Avatar
PPCGeeks Regular
Offline
Pocket PC: HTC Imagio
Carrier: Verizon
Threadstarter
 
Join Date: Oct 2009
Posts: 99
Reputation: 245
jeff_roey is keeping up the good workjeff_roey is keeping up the good workjeff_roey is keeping up the good work
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Bluetooth Connection Slows Everything Down

Quote:
Originally Posted by dmitrynt View Post
i got HTC Imagio and i got same problem with slow phone once it gets BT connection in my car.

I did not understand the workaround. Do i have to remove pim.vol and reload all my contacts?
Simply said the "work-around" for me was to restore an older version of my pim.vol following a hard reset. The thing to keep in mind is my BT worked fine for weeks before it went south. I backup regularly so it was no problem for me to restore my pim.vol using a version that was in-use during t he working time.

If you don't have a backup of your pim.vol or if you never had your BT working, I'm not sure what alternative you have. One thing I would try: clear your call log and attempt a re-connect.

If that doesn't work, I would look into how you can baseline your pim.vol without hard resetting. In other words, if you shut off TF3D, rename your pim.vol to pim.vol.old, soft reset, and restart TF3D . . . will TF3D create a new, blank pim.vol????

That's a question I would suggest you try have answered by someone smarter than me in the forums before you tried it
Reply With Quote
  #5 (permalink)  
Old 01-19-2010, 02:33 PM
nickoko's Avatar
Lurker
Offline
Pocket PC: HTC Imagio
Carrier: Verizon Wireless
 
Join Date: Dec 2009
Posts: 1
Reputation: 0
nickoko is a n00b
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Bluetooth Connection Slows Everything Down

FYI, I have the same problem (2009 GMC Acadia). Bluetooth worked fine for a while, then it started making things extremely slow. I saw this thread at that point and thought about experimenting with my pim.vol file, but decided to just do a hard reset.

At that point I re-synced with Outlook to get all of my contacts back, and everything was working fine - for a few weeks. I am now back to the extremely slow phone when connected to bluetooth in my car. I guess it is time for some troubleshooting.
Reply With Quote
  #6 (permalink)  
Old 05-02-2010, 03:41 PM
traumadog's Avatar
N00b
Offline
Pocket PC: HTC Touch Pro 2
Carrier: Verizon Wireless
 
Join Date: Jan 2010
Posts: 29
Reputation: 10
traumadog is a n00b
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Bluetooth Connection Slows Everything Down

Quote:
Originally Posted by nickoko View Post
FYI, I have the same problem (2009 GMC Acadia). Bluetooth worked fine for a while, then it started making things extremely slow. I saw this thread at that point and thought about experimenting with my pim.vol file, but decided to just do a hard reset.

At that point I re-synced with Outlook to get all of my contacts back, and everything was working fine - for a few weeks. I am now back to the extremely slow phone when connected to bluetooth in my car. I guess it is time for some troubleshooting.
I'll have to see what turns up - this happens with my Acadia/TP2 as well.
Reply With Quote
  #7 (permalink)  
Old 05-02-2010, 04:30 PM
johncal's Avatar
PPCGeeks Regular
Offline
Pocket PC: HTC Imagio
Carrier: Verizon
 
Join Date: Nov 2009
Posts: 145
Reputation: 65
johncal is becoming a great contributor
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Bluetooth Connection Slows Everything Down

Have any of you guys upgraded to MR1? It's supposed to fix the bluetooth stack.
Reply With Quote
  #8 (permalink)  
Old 05-02-2010, 07:36 PM
jeff_roey's Avatar
PPCGeeks Regular
Offline
Pocket PC: HTC Imagio
Carrier: Verizon
Threadstarter
 
Join Date: Oct 2009
Posts: 99
Reputation: 245
jeff_roey is keeping up the good workjeff_roey is keeping up the good workjeff_roey is keeping up the good work
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Bluetooth Connection Slows Everything Down

Quote:
Originally Posted by johncal View Post
Have any of you guys upgraded to MR1? It's supposed to fix the bluetooth stack.
I've updated and agree the BT stack seems much improved (call quality, connectivity, etc.) but it doesn't seem to have solved this issue. I still experience this issue on occassion and have to rebuild my pim.vol. I've sort of adapted to it and keep known copies of a working pim.vol at the ready.

I use SPB Backup and I'm starting to wonder if its backup feature could be at the root of the problem. I've been swapping ROMs so much lately it's hard to tie a pim.vol going south to a backup but it's just a hunch.
Reply With Quote
  #9 (permalink)  
Old 05-02-2010, 08:29 PM
johncal's Avatar
PPCGeeks Regular
Offline
Pocket PC: HTC Imagio
Carrier: Verizon
 
Join Date: Nov 2009
Posts: 145
Reputation: 65
johncal is becoming a great contributor
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Bluetooth Connection Slows Everything Down

Quote:
Originally Posted by jeff_roey View Post
I've updated and agree the BT stack seems much improved (call quality, connectivity, etc.) but it doesn't seem to have solved this issue. I still experience this issue on occassion and have to rebuild my pim.vol. I've sort of adapted to it and keep known copies of a working pim.vol at the ready.

I use SPB Backup and I'm starting to wonder if its backup feature could be at the root of the problem. I've been swapping ROMs so much lately it's hard to tie a pim.vol going south to a backup but it's just a hunch.
Could be, but you can always do selective restores.
Reply With Quote
  #10 (permalink)  
Old 05-10-2010, 12:18 PM
MegaZapFan's Avatar
PPCGeeks Regular
Offline
Pocket PC: Imagio
Carrier: VZW
 
Join Date: Dec 2009
Posts: 91
Reputation: 35
MegaZapFan is just getting started
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Bluetooth Connection Slows Everything Down

Quote:
Originally Posted by johncal View Post
Have any of you guys upgraded to MR1? It's supposed to fix the bluetooth stack.
I have the same issue with my car. BT works fine for a period of time after a hard reset and reinstall of apps, then eventualyl slows down.

I'm running ROM version 3.04.605.7

what is the "MR1" you mention above? Do I have that already with this ROM version?

EDIT: Found the link, looks like that *is* the 3.04 ROM, right? If so, the answer's yes, the slow-when-using-bluetooth issue still happens with this ROM.

Last edited by MegaZapFan; 05-10-2010 at 12:29 PM.
Reply With Quote
Reply

  PPCGeeks > Windows Mobile > WM HTC Devices > HTC Imagio

Tags
bluetooth, lag, performance

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


All times are GMT -4. The time now is 03:05 PM.


Powered by vBulletin® ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
©2012 - PPCGeeks.com