View Single Post
  #6 (permalink)  
Old 02-13-2012, 12:37 AM
mbellot's Avatar
PPCGeeks Regular
Join Date: Jul 2010
Posts: 156
Reputation: 135
mbellot is keeping up the good workmbellot is keeping up the good work
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: [TESTING] CDMA rhod AGPS (XTRA) support

Originally Posted by detule View Post
Downloading xtra.bin is currently not part of the gps init sequence (which is a mistake), rather, it is controlled as part of a frameworks call that is related to updating the network state. So to answer your question : "it depends" on the build you are using, and how it handles the HAL init/de-init sequence. The good news is, there is infrastructure for the gps library itself to ask Android to initiate download of the xtra binary and to pass it along for an injection. Later down the road we can implement this in the gps init sequence.
Fair enough, we are in a testing thread.

Originally Posted by detule View Post
I just took a look at your log and I see the same sequence of trailing dispatches after the injection is over, so I assume the gps lock never worked for you. Could you try manually asking for the injection by using tytung's aGPS Injector?
I was actually inside for that whole sequence.

I tried another test this evening (no logs, sorry). Pulled the battery around 4:30pm. Took the phone out with me tonight around 5pm while doing some grilling in the snow, popped the battery in and booted the phone (left GPS on before I did the battery pull). The phone booted, I loaded Maps and had a lock in something like 15-20 seconds. Maps claimed +/- 10 meters accuracy.

If a cold start set of logs while outside would be useful let me know and I'll do it up.

I'm going to beat on it a little tomorrow, using it for navigation to and from work.