View Single Post
Old 01-01-2010, 11:01 PM
ziggy471's Avatar
Geek with a Gun
Location: NoVA
Join Date: Oct 2009
Posts: 744
Reputation: 6575
ziggy471 is a trusted member of the communityziggy471 is a trusted member of the communityziggy471 is a trusted member of the communityziggy471 is a trusted member of the communityziggy471 is a trusted member of the communityziggy471 is a trusted member of the communityziggy471 is a trusted member of the communityziggy471 is a trusted member of the communityziggy471 is a trusted member of the communityziggy471 is a trusted member of the communityziggy471 is a trusted member of the community
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Fix/Workaround for 2016 Issue

First off, read the WHOLE post, there are things for n00b’s and HardCore users alike.

The Rilphone files posted here are for CDMA/GSM TouchPro2 only, use on any other phone may require a Hard Reset for your phone to work again.

1/27 - Added the 6.1 21052 Rilphone, since many users have been asking for it.
Also to clarify, the USC Rilphone cab is 6.5 21874.

1/16 - Just cabbed the USCC Rilphone for anyone using War or any ROM that uses the USCC OEMDrivers. This is from the Official HTC update posted last night for the USCC phones. If you want to fix the dates in existing messages, make sure to download and run the CorrectSMSDate also.
I tested it on War 12-30 and if Sci was around he would have said 'works like a champ'.

Here's the workaround for the 2016 bug, it's already been tested by many many users:


You might also need this one, I didn't on MightROM War, but other 2.5 with Native HTC Messaging might:

[HKEY_LOCAL_MACHINE\Software\ Jataayu\Messaging\SMS]

If you would rather not do registry edits by hand, there is a CAB attached.

For those that don't know how to install CAB files, here's a nice little video:

What this workaround does is that it tells the phone to date the incoming messages with the current time on the phone. This can be a problem if you have the phone turned off when the message was originally sent to you. When your phone is turned back on, it will receive all the messages sent to it while it was off, and date them at that time.

This is the default way that Verizon has their phones setup, so since I’ve been with them forever, and already had that key set, I didn’t notice the issue. Scientific had the issue, so I started looking through my ‘tweaks’ and found this key and had him try it. His response was ‘It works like a Champ’, so I posted it. I thought it originally was a Fix and not a workaround and posted it as such, again I’ve been with VZW forever, and thought this is how the SMS messages should be dated.

If you have a ROM build with the SSK Kitchen, Calkulin’s Kitchen or BuildOS (with Verizon selected), this will not be an issue for you, since they already have the key in there. There are probably more ROM’s out there that set this in their Provisioning CABs, but I’m not going to download them all to check, I’m on MightROM War, and have no desire to change, been running MightyROM’s since 10-29 and LOVE THEM. Sorry to the other Chef’s I know you work hard on your ROM’s, I just plan on sticking with Mike for now.

With that said, I’m still looking into whether this can be fixed on the phone another way, read patch either SMS.dll or RILPHONE.dll, since RILPHONE.dll is the only one that I’ve found that reads the key.

The screen shots that I attached are from War 12-30 in Native HTC Messaging, in other words, it doesn’t show the year, but it does show that they were on the correct day.

If you already have messages dated from 2016, you’re options are to delete them or to do the following:
1.Backup your messages with PPCPimBackup
2.Uncheck the “Binary backup (faster)” option
3.Connect your phone, and select use as Disk Drive
4.Open Windows Explorer or My computer or hit “Windows Key”-E
5.Go to your PPC SD Card, the new Removable Disk that just appeared
6.I use 7-Zip for my compression program, so right click on the PIMBackup_YYYYMMDD.pib file, select 7-Zip->Open archive. If you need 7-Zip:
7.Extract the msgs_YYYYMMDD.csm file
8.Using Excel, import the file as a semi-colon delimted text file. Open file, select the delimiter as semi-colon.
9.Now press ‘Ctrl’-H, find and replace, in the ‘Find what’ field, enter ‘2016,01,01’ (It’s YYYY,MM,DD,HH,mm,SS), and in the ‘Replace with’ filed, enter ‘2010,01,01’. Change the day or leave it out, that’s your option.
10.Exit Excel, when asked if you want to keep it in Unicode Text format, select Yes.
11.Copy the msgs_YYYYMMDD.csm file back to your SD card, you should still have it connected as a Disk Drive. You ONLY need the ‘.csm’ file.
12.Disconnect your phone from the computer.
13.Open File Explorer on your phone.
14.Click on the msgs_YYYYMMDD.csm file, it should now open PPCPimBackup for you in restore mode.
15.Click ‘Next’ then ‘Next’. On the ‘Restore options’ page, leave it at the default, ‘Delete all existing messages from the Database’
16.Click Done, it will now restore your messages.
17.Soft reset for good measure.

Now here's a better way to fix your timestamps on SMS messages from the future. I just attached the CorrectSMSDate program from the Diamond and Touch Pro SMS fix cab file. Just extract the exe from the zip, copy to your phone and run.

Attached Files
File Type: cab Ziggy 2016 (1.3 KB, 5419 views) Click for barcode!
File Type: zip (3.9 KB, 1975 views) Click for barcode!
File Type: cab Ziggy471 USCC (551.0 KB, 504 views) Click for barcode!
File Type: cab Ziggy471 61 (568.6 KB, 239 views) Click for barcode!

Last edited by ziggy471; 01-28-2010 at 11:54 AM.
Reply With Quote
This post has been thanked 196 times.