PPCGeeks

PPCGeeks (http://forum.ppcgeeks.com/)
-   HTC Touch Pro (http://forum.ppcgeeks.com/htc-touch-pro/)
-   -   Having Issues with .Net Compact Framework (http://forum.ppcgeeks.com/htc-touch-pro/58848-having-issues-net-compact-framework.html)

kdps105 02-23-2009 01:39 AM

Having Issues with .Net Compact Framework
 
Ok First off I have been gone from the forum for about 6 months and was carrying a Blackberry Curve (I know I know don't flame me), but i am back with a new Touch Pro and I love it. Now my problem: I have a couple of different programs that require .Net Compact Framework 3.5 and every time I run them I get the usual error. I have downloaded .Net Compact Framework 3.5 and tried to install it on my pro. I then get this message that 3.5 already exists on my device and it wont install. I am pretty good at figuring out my own problems but I have no idea on this any help is greatly appreciated](*,)

Darkness231 02-23-2009 08:23 AM

Re: Having Issues with .Net Compact Framework
 
Do you have a custom ROM or is it OEM?
Many custom ROMs have it built in, and if you try to install it then it may give you errors.

jdignazio 02-23-2009 08:29 AM

Re: Having Issues with .Net Compact Framework
 
F.Y.I, most custom roms have 3.5 cooked in already. You may be having a problem launching a program (like i did) and it says you need a version of .net cf to run the program, so you think you need to install it right? If this is the case try deleting the program folder off your sd card(go to storage card/program files/and whatever program your having a problem running and delete the folder for that program and try re-installing the program. Worked for me. In my case I had the stock sprint rom before installing K.K s rom, when i tried to run W.V.D it said a need a version of .net cf to run the program, so since I didnt start installing all my cabs, I just deleted the old programs files stores on my sd card. Not sure If this is the case for you, but just a thought.

kdps105 02-23-2009 12:24 PM

Re: Having Issues with .Net Compact Framework
 
Thanks for the responses it is a stock rom and i will try the deleting program files. I'll report back a little later

kdps105 02-23-2009 02:19 PM

Re: Having Issues with .Net Compact Framework
 
ok I went to storage card/program files and there is no folders in there for the programs i am having problems with the programs are the Saturn Liberty Desktop and Pocket Shield. I tried to find the .net cf 3.5 in the windows rom folder to delete it and couldnt find it. So now I am back at square 1 and i am trying to avoid a hard reset.

speck 02-23-2009 04:30 PM

Re: Having Issues with .Net Compact Framework
 
1 Attachment(s)
Try using this - it is Microsoft's dotnet configuration tool. It will let you verify which version(s) of dotnet CF you have installed. If the tool says everything is installed ok - maybe what you are trying to run needs a particular version. You can set which version of dotnet to use for a specific application on the 'Application Policy' tab. On the 'Device Policy' tab, you can set which version of dotnet to use by default (for apps not specified on the App tab).

This originally came from a MS 'power toys' pack. Someone had given me a cab of it, but the cab included other things - so I extracted the file and made a new cab. This is the first cab I've ever created (crash course in the last hour or so), but I did test it by installing it on my own phone. (and uninstalled it and re-installed it to be sure).

The cab will only:
Copy netcfcfg.exe to your \Windows directory
Create a shortcut to it in \Start Menu\Programs

Let me know if you have any problems with the cab. I don't know if it will solve your problem, but at least maybe you can tell what WM thinks is installed.

kdps105 02-23-2009 05:48 PM

Re: Having Issues with .Net Compact Framework
 
Thanks to everyone who responded I finally got it. Speck i already had net config on my device and it said i had 3.5 but i still had the problems. So i found the program files werent on my card they were in the phone memory so i deleted both i was having problems with and installed the netconfig cab speck posted letting it replace the one i already had. then when i ran it, it said i only had version 2. something so i installed 3.5 with no problems and reinstalled the two programs and they are working Thanks alot guys very appreciative


All times are GMT -4. The time now is 11:51 AM.

Powered by vBulletin® ©2000 - 2020, Jelsoft Enterprises Ltd.
©2012 - PPCGeeks.com


Content Relevant URLs by vBSEO 3.6.0