PPCGeeks

PPCGeeks (http://forum.ppcgeeks.com/)
-   HTC Touch Pro 2 (http://forum.ppcgeeks.com/htc-touch-pro-2/)
-   -   Fix/Workaround for 2016 Issue (http://forum.ppcgeeks.com/htc-touch-pro-2/104248-fix-workaround-2016-issue.html)

ziggy471 01-01-2010 11:01 PM

Fix/Workaround for 2016 Issue
 
4 Attachment(s)
First off, read the WHOLE post, there are things for n00b’s and HardCore users alike.

The Rilphone files posted here are for CDMA/GSM TouchPro2 only, use on any other phone may require a Hard Reset for your phone to work again.

1/27 - Added the 6.1 21052 Rilphone, since many users have been asking for it.
Also to clarify, the USC Rilphone cab is 6.5 21874.


1/16 - Just cabbed the USCC Rilphone for anyone using War or any ROM that uses the USCC OEMDrivers. This is from the Official HTC update posted last night for the USCC phones. If you want to fix the dates in existing messages, make sure to download and run the CorrectSMSDate also.
I tested it on War 12-30 and if Sci was around he would have said 'works like a champ'.


Here's the workaround for the 2016 bug, it's already been tested by many many users:

[HKEY_LOCAL_MACHINE\Software\OEM\SMS]
"RecvTimeStamp"=dword:00000001

You might also need this one, I didn't on MightROM War, but other 2.5 with Native HTC Messaging might:

[HKEY_LOCAL_MACHINE\Software\ Jataayu\Messaging\SMS]
“UseSystemTimeAsRecvTime”=dword:00000001

If you would rather not do registry edits by hand, there is a CAB attached.

For those that don't know how to install CAB files, here's a nice little video:
http://www.mobiletopsoft.com/board/2...pocket-pc.html


What this workaround does is that it tells the phone to date the incoming messages with the current time on the phone. This can be a problem if you have the phone turned off when the message was originally sent to you. When your phone is turned back on, it will receive all the messages sent to it while it was off, and date them at that time.

This is the default way that Verizon has their phones setup, so since I’ve been with them forever, and already had that key set, I didn’t notice the issue. Scientific had the issue, so I started looking through my ‘tweaks’ and found this key and had him try it. His response was ‘It works like a Champ’, so I posted it. I thought it originally was a Fix and not a workaround and posted it as such, again I’ve been with VZW forever, and thought this is how the SMS messages should be dated.

If you have a ROM build with the SSK Kitchen, Calkulin’s Kitchen or PPCKitchen.org BuildOS (with Verizon selected), this will not be an issue for you, since they already have the key in there. There are probably more ROM’s out there that set this in their Provisioning CABs, but I’m not going to download them all to check, I’m on MightROM War, and have no desire to change, been running MightyROM’s since 10-29 and LOVE THEM. Sorry to the other Chef’s I know you work hard on your ROM’s, I just plan on sticking with Mike for now.

With that said, I’m still looking into whether this can be fixed on the phone another way, read patch either SMS.dll or RILPHONE.dll, since RILPHONE.dll is the only one that I’ve found that reads the key.

The screen shots that I attached are from War 12-30 in Native HTC Messaging, in other words, it doesn’t show the year, but it does show that they were on the correct day.

If you already have messages dated from 2016, you’re options are to delete them or to do the following:
1.Backup your messages with PPCPimBackup
http://www.pocketpcfreeware.com/en/index.php?soft=1806
2.Uncheck the “Binary backup (faster)” option
3.Connect your phone, and select use as Disk Drive
4.Open Windows Explorer or My computer or hit “Windows Key”-E
5.Go to your PPC SD Card, the new Removable Disk that just appeared
6.I use 7-Zip for my compression program, so right click on the PIMBackup_YYYYMMDD.pib file, select 7-Zip->Open archive. If you need 7-Zip: http://www.7-zip.org/download.html
7.Extract the msgs_YYYYMMDD.csm file
8.Using Excel, import the file as a semi-colon delimted text file. Open file, select the delimiter as semi-colon.
9.Now press ‘Ctrl’-H, find and replace, in the ‘Find what’ field, enter ‘2016,01,01’ (It’s YYYY,MM,DD,HH,mm,SS), and in the ‘Replace with’ filed, enter ‘2010,01,01’. Change the day or leave it out, that’s your option.
10.Exit Excel, when asked if you want to keep it in Unicode Text format, select Yes.
11.Copy the msgs_YYYYMMDD.csm file back to your SD card, you should still have it connected as a Disk Drive. You ONLY need the ‘.csm’ file.
12.Disconnect your phone from the computer.
13.Open File Explorer on your phone.
14.Click on the msgs_YYYYMMDD.csm file, it should now open PPCPimBackup for you in restore mode.
15.Click ‘Next’ then ‘Next’. On the ‘Restore options’ page, leave it at the default, ‘Delete all existing messages from the Database’
16.Click Done, it will now restore your messages.
17.Soft reset for good measure.

Now here's a better way to fix your timestamps on SMS messages from the future. I just attached the CorrectSMSDate program from the Diamond and Touch Pro SMS fix cab file. Just extract the exe from the zip, copy to your phone and run.


Z

psycho_maniac 01-01-2010 11:07 PM

Re: Fix for 2016 Issue
 
so is this just a work around or really a fix? i still would like the date and time in my timestamps

japper88 01-01-2010 11:10 PM

Re: Fix for 2016 Issue
 
any confirmation if this actually works?

HTC_TP 01-01-2010 11:13 PM

Re: Fix for 2016 Issue
 
Some further detail documentation as to what this change does please? This REG edit has been around for a long time and some confirmation is necessary please.

NeroDan 01-01-2010 11:14 PM

Re: Fix for 2016 Issue
 
Confirmed. Working for me.

ziggy471 01-01-2010 11:21 PM

Re: Fix for 2016 Issue
 
Quote:

Originally Posted by japper88 (Post 1454438)
any confirmation if this actually works?

Quote:

Originally Posted by HTC_TP (Post 1454447)
Some further detail documentation as to what this change does please? This REG edit has been around for a long time and some confirmation is necessary please.

Quote:

Originally Posted by NeroDan (Post 1454450)
Confirmed. Working for me.

Since I didn't have this issue, I started looking at my reg files that I import from SDConfig for MM War. I noticed this one, don't remember why I set it, probably because I could, and since Scientific had the same issue, I had him test it, and it worked.

I did edit the first post with another key I found today while dis-assembling the HTC Messaging client trying to find a fix for the Sprint users. It should also work for anyone using native HTC Messaging on 2.5.1922, but I haven't tested that one.

NeroDan, thanks for the confirmation, now I can confirm three working.


Z

psycho_maniac 01-01-2010 11:24 PM

Re: Fix for 2016 Issue
 
how bout a confirmed screenshot?

dOOfus 01-01-2010 11:24 PM

Re: Fix for 2016 Issue
 
working on sprint tp2 energy phoenix, but didn't fix the msgs that were already messed up

thanks

1999TL 01-01-2010 11:27 PM

Re: Fix for 2016 Issue
 
I tried the 2.5 fix. didn't work. Is there a space b/w the time? Also, I didn't have that entry. I had to create it?

coppertop24 01-01-2010 11:27 PM

Re: Fix for 2016 Issue
 
just did the first reg edit, worked for my MightyROM REV. 12/30. also checked my gf's TP1 that wasnt having the issue and she already had this entry.


All times are GMT -4. The time now is 05:18 PM.

Powered by vBulletin® ©2000 - 2019, Jelsoft Enterprises Ltd.
©2012 - PPCGeeks.com


Content Relevant URLs by vBSEO 3.6.0