PPCGeeks

PPCGeeks (http://forum.ppcgeeks.com/)
-   HTC Titan (http://forum.ppcgeeks.com/htc-titan/)
-   -   Preferred Network w / WiFi and EVDO (http://forum.ppcgeeks.com/htc-titan/6460-preferred-network-w-wifi-evdo.html)

htcrob 07-26-2007 10:54 AM

Preferred Network w / WiFi and EVDO
 
Do any know what is the preferred network the phone will use for data when both WiFi and EVDO are enabled? Ideally when WiFi is turned on I would hope that the phone stops using the cellular network and starts using the Wifi network which will be faster.

But i haven't figured out how to test this.

Thanks,

dcd 07-26-2007 02:18 PM

it seems to differ per application...ive been trying to get it to strictly prioritize wifi, but it still uses cellular for some things like activesync, and possibly dns

draghn 08-10-2007 02:59 PM

I'm having an issue getting internet explorer to use the activesync connection for data.

On the old ROM 2.08xxx IE would use activesync just fine. On the new ROM, it won't use it if I don't allow the cellular connection.

IS there a way to prioritize, or at least some setting in PIE that will make it use the activesync connection?

dcd 08-10-2007 03:54 PM

thats what i was talking about with dns - mine is the same way, but then once it resolves it seems to transfer via wifi. i think its using spcs nameservers via cellular connection - which is retarded

draghn 08-13-2007 11:59 AM

After playing with this for a bit, I gave up on it for the rest of the day. Today I plugged my phone into activesync; PIE used that data connection just fine, as well as a few other applications.

I don't think it was any setting I played with as nothing I did seemed to work when I was focusing on it. If I find out exactly what I did, I will post it, but all of my settings seem to be the same as when data over activesync was not working.

Note: the battery on my phone did run to 0% and turned itself off over the weekend.

borealcool 08-13-2007 12:25 PM

That has got to be one of the more frustrating "features" of this phone, it has a mind of its own when it comes to choosing data connections. If you live in Canada where price gouging data is the norm, you end up like this poor soul with a 350$ data invoice. There is a radical solution though.

canospinach 10-25-2007 02:54 PM

Any further feedback on this?
 
Quote:

Originally Posted by borealcool (Post 74249)
That has got to be one of the more frustrating "features" of this phone, it has a mind of its own when it comes to choosing data connections. If you live in Canada where price gouging data is the norm, you end up like this poor soul with a 350$ data invoice. There is a radical solution though.


I see this subject died a while ago... so bump it is.


Any further feedback on this?


I have 2 real situations i am researching:

1) I need to tell it to handoff data from Ev-DO to Wi-fi and vice versa based upon Wi-Fi Signal strength (think how UMA handoff works)

2) Want EvDO to automatically start when needed, but just not when a Wi-Fi signal is present

It seems we have many options to completely disable it using scripts and regkeys (many GPRS & EvDO options). I guess i am looking for a little more than just to toggle it on and off.

I have a guy i work with developing on these ideas, but we can really use any insight or feedback from anyone on this. You dont need to be an expert, just PM me about anything you might know, have heard or seen.

(if you know about UMA/VoIP i started a thread http://forum.ppcgeeks.com/htc-apache/9854-uma-wifi-voip-6700-a.html to discuss)

Thanks in advance,

krisj209 07-19-2008 05:34 PM

Re: Preferred Network w / WiFi and EVDO
 
bump again...

I need this too... what a chore.

Please help!

<<<EDIT>>>

Ok, I found what I was looking for. It may not be the solution you need but i am sure stoked.

My problem was that if I opened internet exploder it would connect via cellular data even if there was a working (and way faster) wifi connection. It would then use the cellular connection for the data transfers. If I went into the commanager and disconnected the cellular data, it would just reconnect.

Here is what I did to fix it.

Start>Settings>Connections tab... Connections. Under "My Work Network" add a new modem connection to your cell provider. I dont know what your providers settings will be but I just copied the info from the "My Isp" settings for "My Connection".

Now when I am connected via wifi, the cellular data connection does not even try to connect. If I shut off the wifi, the cellular modem dials in and connects.

Now I am going to go poke around and find the reg hack for auto disconnect evdo after 1 minute to save batt life.

I hope this helps someone.


All times are GMT -4. The time now is 09:02 PM.

Powered by vBulletin® ©2000 - 2020, Jelsoft Enterprises Ltd.
©2012 - PPCGeeks.com


Content Relevant URLs by vBSEO 3.6.0