PPCGeeks

PPCGeeks (http://forum.ppcgeeks.com/)
-   HTC Titan (http://forum.ppcgeeks.com/htc-titan/)
-   -   WiFi Unavailable (http://forum.ppcgeeks.com/htc-titan/35469-wifi-unavailable.html)

Gulanowski 08-22-2008 01:37 AM

WiFi Unavailable
 
Weird issue that there doesn't seem to be a solution to (did numerous searches). When I turn Wifi on via the switch it shows the little icon and then immediatly says in the connection box on the today screen "Wifi: Unavailable". I am 100% sure that I am within range of multiple wireless routers as well as 2 feet away from my access point.

Also, I am able to use WMWifirouter on the phone, which leads me to believe that my phone is stuck in some weird kind of mode where it isn't seeing any wireless routers or access points.

I've soft reset 5 times and still nothing is working. Any help would be much appreciated at this point.

shaggylive 08-22-2008 01:50 AM

Re: WiFi Unavailable
 
Quote:

Originally Posted by shaggylive (Post 390686)
have you tried adjusting the Power Mode settings in the Wireless LAN cpl?
other than that, you may have overheated your chip.. I think I may have done the same with mine today... :( try putting it infront of the A/C and see if it works...

what was wrong with the thread you started here http://forum.ppcgeeks.com/htc-titan/35432-wifi-3-42-radio.html

Gulanowski 08-22-2008 01:57 AM

Re: WiFi Unavailable
 
Quote:

Originally Posted by shaggylive (Post 390748)
what was wrong with the thread you started here http://forum.ppcgeeks.com/showthread.php?t=35432

I thought the title was misleading as I don't think it's related to the radio at all. The title also didn't address the actual issue, I thought it was too vague.

I tried your power suggestion btw to no avail. Do you really think it overheated?

shaggylive 08-22-2008 02:12 AM

Re: WiFi Unavailable
 
that's my best guess, kevinK has reported that his only works when cool, and we both think it's a hardware issue, likely caused by global warming.... lol,, ok could't resist something else to blame on co2. ;)
no seriously, try it after the phone's been OFF (no power) a while and see if it works until it gets hot, or put in front of a cranked A/C vent.

Gulanowski 08-22-2008 12:55 PM

Re: WiFi Unavailable
 
Quote:

Originally Posted by shaggylive (Post 390755)
that's my best guess, kevinK has reported that his only works when cool, and we both think it's a hardware issue, likely caused by global warming.... lol,, ok could't resist something else to blame on co2. ;)
no seriously, try it after the phone's been OFF (no power) a while and see if it works until it gets hot, or put in front of a cranked A/C vent.

So we're thinking maybe a safety mechanism here that shuts down the Wifi when it overheats? It's strange, that's never happened before I use it alot when I'm sitting at home. It just had 10 hours to cool down overnight in a 65 degree room and it's still not working.

I'm gonna give what you recommend a shot, but I have a feeling it's something else going on, no disrespect to you (I appreciate the help). This issue seemed to happen when I removed the settings for the only access point that it was veiwing in the Wifi settings, now it just says, and I quote, "Wi-Fi: Unavailable" on the today screen immediately upon turning the switch on, it doesn't even look for connections.

EDIT: Did what you recommended shaggy. Ice cold air vent with the phone off. Didn't seem to work. I honestly think this is a software issue, but I can't find anyone else that had the same problem.

shaggylive 08-22-2008 03:42 PM

Re: WiFi Unavailable
 
good to hear! if find it much easier to isolate possible h/w issues rather than looking for the bug in software..

so, what rom are you running? would it be a pain to hard-reset? another thing you could try is re-flashing the radio, as that won't wipe you programs/settings

Edit\/\/\/ (for the sake of clarity) \/
Quote:

Originally Posted by Gulanowski (Post 391024)
So we're thinking maybe a safety mechanism here that shuts down the Wifi when it overheats?

No, more like a limitation/flaw of silicone/copper/metal based chips. once they overheat, your lucky if they work at all, and then only when cool.


Edit2. also, I think a software "safety mechanism" would be a great idea!!! I'm going to look into this, and if someone beats me to the punch, I'll DONATE.

Gulanowski 08-22-2008 04:50 PM

Re: WiFi Unavailable
 
Quote:

Originally Posted by shaggylive (Post 391185)
good to hear! if find it much easier to isolate possible h/w issues rather than looking for the bug in software..

so, what rom are you running? would it be a pain to hard-reset? another thing you could try is re-flashing the radio, as that won't wipe you programs/settings

Thanks again shaggy. I think this is relatedto WmWifirouter, that somehow screwed it up. I've had issue's with it before but nothing like this. I've tried uninstalling it and I cant. I'm gonna have to do some esearch on that now I suppose.

I wasn't aware you could reflash a radio without losing the phones data. If you could provide me with a bit more info on that I'd much appreciate it.

shaggylive 08-22-2008 05:02 PM

Re: WiFi Unavailable
 
Quote:

Originally Posted by Gulanowski (Post 391241)
Thanks again shaggy. I think this is relatedto WmWifirouter, that somehow screwed it up. I've had issue's with it before but nothing like this. I've tried uninstalling it and I cant. I'm gonna have to do some esearch on that now I suppose.

I wasn't aware you could reflash a radio without losing the phones data. If you could provide me with a bit more info on that I'd much appreciate it.

unfortunately I'm not much help on this... I've not used wifirouter and I'm on sprint. Also I don't usually upgrade my radio until a new official rom puts it on, but I have done just the radio only, just not for quite a while..

TweetyBear 08-22-2008 05:13 PM

Re: WiFi Unavailable
 
i use wifirouter with no problems. i'm not sure what's wrong with your wifi.

Gulanowski 08-22-2008 06:12 PM

Re: WiFi Unavailable
 
I figured it out, it was not a hardware issue. Here's the story in case youre interested.

Since I was having trouble uninstalling WmWifirouter I started doing some google searches to see if others were having a similar issue. There indeed are. I then came across people having the same problem as myself, and a fellow over at xda attached a cab that reset some settings on my phone that were altered by WMWifirouter. The cab worked nicely, wifi is working again. Only problem is WMWifirouter is still listed as an installed program and the icon is in my programs section, and every time I soft reset it creates that little WMWifirouter entry in my wireless networks. http://forum.xda-developers.com/show...357152&page=73, post #728 is what I'm referring to.

I've been reading about a bunch of versions of WMWifirouter, some work well on the Titan while others cause issue's.


All times are GMT -4. The time now is 11:32 PM.

Powered by vBulletin® ©2000 - 2020, Jelsoft Enterprises Ltd.
©2012 - PPCGeeks.com


Content Relevant URLs by vBSEO 3.6.0