PPCGeeks Forums HTC Arrive HTC HD2 HTC Thunderbolt HTC Touch Pro 2 HTC Evo 4G HTC Evo 3D Samsung Galaxy S II Motorola Droid X Apple iPhone Blackberry
Go Back   PPCGeeks > Windows Mobile > WM HTC Devices > HTC Imagio
Connect with Facebook

Notices



Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 03-10-2010, 11:25 AM
Rollercat's Avatar
Lurker
Offline
Pocket PC: HTC Imagio
Carrier: Verizon
 
Join Date: Mar 2010
Posts: 2
Reputation: 0
Rollercat is a n00b
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Emails not deleting on Outlook exchange server

When I delete an email on my Imagio it does not delete the email on the Outlook exchange server.

Does anyone know where I can find the setting to make this work (if such a setting exists that is).

Many thanks!
Reply With Quote
  #2 (permalink)  
Old 03-10-2010, 11:55 AM
cslawren's Avatar
PPCGeeks Regular
Offline
Pocket PC: HTC Imagio
Carrier: Verizon Wireless
 
Join Date: Nov 2009
Posts: 199
Reputation: 145
cslawren is keeping up the good workcslawren is keeping up the good work
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Emails not deleting on Outlook exchange server

I've noticed the same thing, but they do actually delete later. I think the server pushes to the device, but when you delete messages, the phone doesn't necessarily "push" to the server.
__________________
If I helped in any way, please press the button! Currently running:
ROM:
Drellisdee Whitestone RC1.4
SYS: Windows Mobile 6.5.5 23568
Reply With Quote
  #3 (permalink)  
Old 03-10-2010, 12:10 PM
robocrop's Avatar
PPCGeeks Regular
Offline
Pocket PC: Imagio
Carrier: Verizon
 
Join Date: Dec 2009
Posts: 74
Reputation: 55
robocrop is becoming a great contributor
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Emails not deleting on Outlook exchange server

I see the same thing. The server pushes to the device. The device synchs back to the server. I am not sure what the synch time is while you are in push mode.
Reply With Quote
  #4 (permalink)  
Old 03-10-2010, 12:14 PM
jeff_roey's Avatar
PPCGeeks Regular
Offline
Pocket PC: HTC Imagio
Carrier: Verizon
 
Join Date: Oct 2009
Posts: 99
Reputation: 245
jeff_roey is keeping up the good workjeff_roey is keeping up the good workjeff_roey is keeping up the good work
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Emails not deleting on Outlook exchange server

I'm sure you checked this:

(1) From Email Inbox go to: Menu -> Tools -> Options . . . -> and tap on your email account.

(2) Tap Send/Receive Schedule -> Advanced Settings -> and make sure the "When Deleting Messages" pull-down shows "Delete Them Off The Server"
Reply With Quote
  #5 (permalink)  
Old 03-10-2010, 03:26 PM
blue_94_trooper's Avatar
N00b
Offline
Pocket PC: HTC Imagio
Carrier: Verizon
 
Join Date: Nov 2009
Posts: 49
Reputation: 25
blue_94_trooper is just getting started
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Emails not deleting on Outlook exchange server

Quote:
Originally Posted by jeff_roey View Post
I'm sure you checked this:

(1) From Email Inbox go to: Menu -> Tools -> Options . . . -> and tap on your email account.

(2) Tap Send/Receive Schedule -> Advanced Settings -> and make sure the "When Deleting Messages" pull-down shows "Delete Them Off The Server"
Those options only exist for POP3/IMAP email accounts. Outlook email using Exchange via ActiveSync does not give you that choice.


edit: I just deleted an email on my phone and it was deleted from my desktop Outlook about 2 minutes later.

edit: I tried it a couple of more times. First time took 2 minutes, second time took 5.

Last edited by blue_94_trooper; 03-10-2010 at 03:43 PM.
Reply With Quote
  #6 (permalink)  
Old 03-10-2010, 09:35 PM
mhrc4's Avatar
PPCGeeks Regular
Offline
Pocket PC: HTC Imagio
Carrier: Verizon Wireless
Location: Southern California
 
Join Date: May 2008
Posts: 244
Reputation: 150
mhrc4 is keeping up the good workmhrc4 is keeping up the good work
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Emails not deleting on Outlook exchange server

okay people, listen up, quick refresher on how ActiveSync works with WM and an Exchange server.

With WM and activesync, when AS is enabled and set to sync "As Items Arrive" what is happening in the background is the phone is maintaining a connection with the exchange server on a consistent basis. As soon as the Exchange server identifies that a new message has hit your mailbox, it sends a command back to AS to trigger a sync. Needless to say, this is still very old school, but it is the same way that Blackberry syncs email with their BES.

The big drawback to the WM and AS solution, is that WM does not have the triggers in your Pocket Outlook to tell AS that when a command is taken on the phone that is not a SEND EMAIL (i.e. a message is moved, deleted, etc) to initiate a sync.

Blue_94_Trooper. what you are probably seeing is that as your phone deletes the items, either another email or event hits your mailbox on the Exchange side and forces AS to initiate a sync, hence the difference in times of deleting an email

This is unfortunately, just how it is. I can attest to this as I have been working as an IT Consultant, Microsoft Certified Exchange engineer for over 8 years now, since "push" technology was rolled out to Windows Mobile.

To give you an idea, I was out today at a personal appointment, checking email, etc. I last got 3 emails around 2:00pm PST. I read them, moved two of them, and left the other in my inbox. I then turned and drove an hour back home. When i sat down and logged into Outlook, all 3 messages were sitting in my Inbox, unread. A quick manual sync of AS, and all 3 were applied the appropriate permissions.

Hope this helped shed a little light on how AS works.
Reply With Quote
This post has been thanked 1 times.
  #7 (permalink)  
Old 03-11-2010, 09:28 AM
blue_94_trooper's Avatar
N00b
Offline
Pocket PC: HTC Imagio
Carrier: Verizon
 
Join Date: Nov 2009
Posts: 49
Reputation: 25
blue_94_trooper is just getting started
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Emails not deleting on Outlook exchange server

Thanks for the info. I was looking for something that might have forced it (e.g. a new email) but there wasn't anything obvious. I'm assuming there was some system event on the Exchange server or the device that forced the sync but for now I can't figure out what it was.
Reply With Quote
Reply

  PPCGeeks > Windows Mobile > WM HTC Devices > HTC Imagio

Tags
delete, email, exchange server, imagio, outlook

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 07:47 AM.


Powered by vBulletin® ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
©2012 - PPCGeeks.com