PPCGeeks Forums HTC Arrive HTC HD2 HTC Thunderbolt HTC Touch Pro 2 HTC Evo 4G HTC Evo 3D Samsung Galaxy S II Motorola Droid X Apple iPhone Blackberry
Go Back   PPCGeeks > Windows Mobile > WM HTC Devices > HTC Diamond

Notices



Reply
 
LinkBack Thread Tools Display Modes
  #11 (permalink)  
Old 05-04-2009, 03:32 PM
a_medina626's Avatar
PPCGeeks Regular
Offline
Pocket PC: Samsung Epic
Carrier: Sprint
Location: Houston, TX
 
Join Date: Oct 2008
Posts: 171
Reputation: 580
a_medina626 knows their stuffa_medina626 knows their stuffa_medina626 knows their stuffa_medina626 knows their stuffa_medina626 knows their stuffa_medina626 knows their stuff
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: [Sprint] Ring & Vibrate no longer sticks

Check the following value in Registry:

[HKEY_CURRENT_USER\ControlPanel\Notifications\{A877 D65A-239C-47a7-9304-0D347F580408}]

"Options"=dword:00000001 - ring only

"Options"=dword:00000011 - vibrate and ring
__________________
If I have helped you with my post please don't forget to hit the THANKS button ...
Reply With Quote
This post has been thanked 1 times.
  #12 (permalink)  
Old 05-04-2009, 04:00 PM
a_medina626's Avatar
PPCGeeks Regular
Offline
Pocket PC: Samsung Epic
Carrier: Sprint
Location: Houston, TX
 
Join Date: Oct 2008
Posts: 171
Reputation: 580
a_medina626 knows their stuffa_medina626 knows their stuffa_medina626 knows their stuffa_medina626 knows their stuffa_medina626 knows their stuffa_medina626 knows their stuff
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: [Sprint] Ring & Vibrate no longer sticks

Just extracted the .RGU file from his ROM. He has the following value cooked into it:

[HKEY_CURRENT_USER\ControlPanel\Notifications\{A877 D65A-239C-47a7-9304-0D347F580408}]
"Default"="Messaging: New e-mail message"
"Wave"="\\Windows\\newemail.mp3"
"Options"=dword:00000001
"Duration"=dword:00000000

I have had roms not let me change cooked settings before so this might be the case. They always seem to revert back after a soft reset. This might be the case for you if your change it and it doesn't stick.

Last edited by a_medina626; 05-04-2009 at 04:37 PM.
Reply With Quote
This post has been thanked 1 times.
  #13 (permalink)  
Old 05-04-2009, 04:47 PM
stravy's Avatar
PPCGeeks Regular
Offline
Pocket PC: iPhone 4
Carrier: AT&T
Location: Lexington, KY
 
Join Date: Oct 2008
Posts: 181
Reputation: 80
stravy is becoming a great contributor
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: [Sprint] Ring & Vibrate no longer sticks

Quote:
Originally Posted by a_medina626 View Post
Just extracted the .RGU file from his ROM. He has the following value cooked into it:

[HKEY_CURRENT_USER\ControlPanel\Notifications\{A877 D65A-239C-47a7-9304-0D347F580408}]
"Default"="Messaging: New e-mail message"
"Wave"="\\Windows\\newemail.mp3"
"Options"=dword:00000001
"Duration"=dword:00000000

I have had roms not let me change cooked settings before so this might be the case. They always seem to revert back after a hard reset. This might be the case for you if you change it and it doesn't stick.
would this cause the intermitent problem i am noticing. perfect example happened today. got work and set my phone to vibrate. got push email all morning long and my phone did not vibrate when i recieved an email. got one phone call and the phone vibrated. after recieving that one phone call the i next couple of emails i received the phone vibrated after that it stopped vibrating for emails. i realize under sounds and notifications that i can set it to both ring and vibrate so when i set the volume level to vibrate it will vibrate on all new email. but this is just a bit of a puzzler for me. i used the stock rom for 3 months. and for 3 months i set the phone to vibrate when i got to work. after i flashed to a custom rom (btw - i am loving the rom...dont get me wrong) the push email notification is intermitent when i have the phone just set to vibrate.

anyway...i sure do apprecate your thoughts.
__________________
You live and learn....just hope you don't brick it!!!
Reply With Quote
  #14 (permalink)  
Old 05-04-2009, 05:05 PM
a_medina626's Avatar
PPCGeeks Regular
Offline
Pocket PC: Samsung Epic
Carrier: Sprint
Location: Houston, TX
 
Join Date: Oct 2008
Posts: 171
Reputation: 580
a_medina626 knows their stuffa_medina626 knows their stuffa_medina626 knows their stuffa_medina626 knows their stuffa_medina626 knows their stuffa_medina626 knows their stuff
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: [Sprint] Ring & Vibrate no longer sticks

Try this:
First set your Sounds & Notifications new email option to only vibrate (just to test)

Then set your Registry to vibrate only:

[HKEY_CURRENT_USER\ControlPanel\Notifications\{A877 D65A-239C-47a7-9304-0D347F580408}]

"Options"=dword:00000010 - vibrate only.

Next turn on the volume to your phone and send yourself a message to see if it vibrates only.

Finally, soft reset and check both of the above settings. If one reverts then it is probably the ROM setting everything back.
Reply With Quote
  #15 (permalink)  
Old 05-04-2009, 05:58 PM
stravy's Avatar
PPCGeeks Regular
Offline
Pocket PC: iPhone 4
Carrier: AT&T
Location: Lexington, KY
 
Join Date: Oct 2008
Posts: 181
Reputation: 80
stravy is becoming a great contributor
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: [Sprint] Ring & Vibrate no longer sticks

nope. neither one changed after the soft reset.

*edit* after reset i changed sounds and notifications for new email to "play sound". changed the system volume back to vibrate and sent a test message. the phone did not vibrate.

before the phone's screen automatically turned off i recieved an email and the phone vibrated. that got me thinking. i tried several tests. i sent several test emails with the phone's screen off and none vibrated. i turnd the screen on and sent a test email and the phone vibrated. so right now it seems when the phone is sleeping it will not wake up when i recieve a new email. it will when i get a text message or an incoming call. where is the setting for that....i am looking

Last edited by stravy; 05-04-2009 at 06:13 PM.
Reply With Quote
  #16 (permalink)  
Old 05-04-2009, 06:18 PM
stravy's Avatar
PPCGeeks Regular
Offline
Pocket PC: iPhone 4
Carrier: AT&T
Location: Lexington, KY
 
Join Date: Oct 2008
Posts: 181
Reputation: 80
stravy is becoming a great contributor
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: [Sprint] Ring & Vibrate no longer sticks

now it stopped vibrating again. nothing has changed the new emails just stopped notifying me with a vibration. like i said it is a very intermittent problem. that i cant nail down.
Reply With Quote
  #17 (permalink)  
Old 05-04-2009, 06:22 PM
scout7's Avatar
PPCGeeks Regular
Offline
Pocket PC: HTC HERO CDMA
Carrier: Sprint
Location: Keller TX
 
Join Date: Nov 2008
Posts: 110
Reputation: 205
scout7 is keeping up the good workscout7 is keeping up the good workscout7 is keeping up the good work
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: [Sprint] Ring & Vibrate no longer sticks

Quote:
Originally Posted by a_medina626 View Post
Go to the registry: [HKEY_CURRENT_USER\ControlPanel\Sounds\RingTone0]

Under there you will see this key: "Script"="apw3r


Change to "av3w3r" , save and soft reset.

The Script reads - activate device, vibrate 3 seconds, wait 3 seconds, repeat.

You can change the number of seconds to your liking, it might not be exactly what you wanted but it still gets you both vibrate and ring.

See attachment for more mods to Registry and explanations of scripts. Just remember that order is important cause it plays whole ringtone first before taking next step. I got these from a post of Rstoyguy.

Good Luck.

Even this reverts back to the original entry after soft reset.
Something in the latest stock rom.
Reply With Quote
This post has been thanked 1 times.
  #18 (permalink)  
Old 05-04-2009, 06:37 PM
a_medina626's Avatar
PPCGeeks Regular
Offline
Pocket PC: Samsung Epic
Carrier: Sprint
Location: Houston, TX
 
Join Date: Oct 2008
Posts: 171
Reputation: 580
a_medina626 knows their stuffa_medina626 knows their stuffa_medina626 knows their stuffa_medina626 knows their stuffa_medina626 knows their stuffa_medina626 knows their stuff
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: [Sprint] Ring & Vibrate no longer sticks

Quote:
Originally Posted by scout7 View Post
Even this reverts back to the original entry after soft reset.
Something in the latest stock rom.
Nice to know...
Reply With Quote
  #19 (permalink)  
Old 05-04-2009, 09:58 PM
matty032's Avatar
Regular 'Geeker
Offline
Pocket PC: Sprint Diamond
Carrier: Sprint
Location: NC
 
Join Date: Apr 2008
Posts: 271
Reputation: 115
matty032 is keeping up the good workmatty032 is keeping up the good work
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: [Sprint] Ring & Vibrate no longer sticks

it has to do with the HTC guardian file in windows folder.
Reply With Quote
  #20 (permalink)  
Old 05-04-2009, 10:23 PM
MrObvious's Avatar
I see you have a PPC.
Offline
Pocket PC: Droid
Carrier: Borged Alltel
Location: Hutchinson, KS
 
Join Date: Nov 2007
Posts: 4,603
Reputation: 3000
MrObvious is still contributing even after becoming a VIPMrObvious is still contributing even after becoming a VIPMrObvious is still contributing even after becoming a VIPMrObvious is still contributing even after becoming a VIPMrObvious is still contributing even after becoming a VIPMrObvious is still contributing even after becoming a VIPMrObvious is still contributing even after becoming a VIPMrObvious is still contributing even after becoming a VIPMrObvious is still contributing even after becoming a VIPMrObvious is still contributing even after becoming a VIPMrObvious is still contributing even after becoming a VIP
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: [Sprint] Ring & Vibrate no longer sticks

How long do you wait to soft reset? I've heard a minute or so.
__________________
Disclaimer: The truth is obvious.
Reply With Quote
Reply

  PPCGeeks > Windows Mobile > WM HTC Devices > HTC Diamond

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


All times are GMT -4. The time now is 05:52 AM.


Powered by vBulletin® ©2000 - 2020, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
©2012 - PPCGeeks.com