PPCGeeks Forums HTC Arrive HTC HD2 HTC Thunderbolt HTC Touch Pro 2 HTC Evo 4G HTC Evo 3D Samsung Galaxy S II Motorola Droid X Apple iPhone Blackberry
Go Back   PPCGeeks > Windows Mobile > WM HTC Devices > HTC Diamond

Notices



Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 05-13-2010, 03:12 PM
designflaw's Avatar
Lurker
Offline
Pocket PC: HTC Diamond
Carrier: Sprint PCS
 
Join Date: Mar 2009
Posts: 6
Reputation: 10
designflaw is a n00b
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
WinMoSquare - .net cf initialization error

I tried to search the forums but could not come up with anything worthwhile so thought I did post here for the gurus.

I have a windows 6.1 htc diamond phone with sprint. Its a cdma phone. I installed the WinMoSquare application but whenever I try to launch it, I get the following error

.net CF initialization error
To run this application, you must first install one of the following versions of the .NET compact framework: v3.5.9198. Contact your application publisher for instructions about obtaining the appropriate version of the .net compact framework.

The kicker is that I do have .net v3.5.9198 installed on my phone, and have select v3.5 as the framework to use with this application. I did this via the .net configuration tool. Also, if I look at the .net configuration tool it gives this information

.net compact framework versions installed:

3.5.9198.0
2.0.7045.0 (ROM)

Windows version:

PocketPC
5.2.20764

and on the 4th tab (application policy), I have selected the WinMoSquare application and choose 3.5.9198 to be used.

Does anyone know how to change the default .net version on windows 6.1?

Thanks,
Reply With Quote
  #2 (permalink)  
Old 05-13-2010, 05:19 PM
horndoctor's Avatar
Suuuper Geeenius
Offline
Pocket PC: hTc RhodiumW (Touch Pro2)
Carrier: Sprint
Location: St. Louis, MO.
 
Join Date: Mar 2009
Posts: 6,764
Reputation: 8384
horndoctor is a trusted member of the communityhorndoctor is a trusted member of the communityhorndoctor is a trusted member of the communityhorndoctor is a trusted member of the communityhorndoctor is a trusted member of the communityhorndoctor is a trusted member of the communityhorndoctor is a trusted member of the communityhorndoctor is a trusted member of the communityhorndoctor is a trusted member of the communityhorndoctor is a trusted member of the communityhorndoctor is a trusted member of the community
Mentioned: 14 Post(s)
Tagged: 0 Thread(s)
Send a message via Yahoo to horndoctor
Wirelessly posted (HTC Diamond: Mozilla/4.0 (compatible; MSIE 6.0; Windows CE; IEMobile 7.11) Sprint MP6950SP)

I don't have/use that app but the only thing that I can think of at the moment would be to uninstall the app first. Then make sure that you have the .net config app set so it runs unconfigured apps with .net 3.5 which is selected on one of the tabs...not sure which one.
Then soft reset. Then reinstall to internal storage and then if that doesn't seem to work then try installing to device.
I hope you can get it working!
__________________
Trombone players do it in 7 positions!
Reply With Quote
  #3 (permalink)  
Old 06-08-2010, 01:39 PM
designflaw's Avatar
Lurker
Offline
Pocket PC: HTC Diamond
Carrier: Sprint PCS
Threadstarter
 
Join Date: Mar 2009
Posts: 6
Reputation: 10
designflaw is a n00b
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: WinMoSquare - .net cf initialization error

Ok, so here is what I have tried

- Uninstalled the app from storage card, soft-reset, changed the default .net framework via registry editor to 3.5.9198.0, soft-reset, installed the app back on storage card ... no dice
- Uninstalled the app from storage card, soft-reset, installed it on the device ... no dice
- removed the app, soft-reset, Changed the default framework to use from .net configuration to 3.5.9198.0 for configured apps, installed the app ... no dice

The error that I still get is that WinMoSquare thinks that I am trying to run it with a lower framework then 3.5.9198.0 where as really I am not.

Does anyone know how to get this to work?
Reply With Quote
  #4 (permalink)  
Old 06-08-2010, 04:21 PM
MrObvious's Avatar
I see you have a PPC.
Offline
Pocket PC: Droid
Carrier: Borged Alltel
Location: Hutchinson, KS
 
Join Date: Nov 2007
Posts: 4,603
Reputation: 3000
MrObvious is still contributing even after becoming a VIPMrObvious is still contributing even after becoming a VIPMrObvious is still contributing even after becoming a VIPMrObvious is still contributing even after becoming a VIPMrObvious is still contributing even after becoming a VIPMrObvious is still contributing even after becoming a VIPMrObvious is still contributing even after becoming a VIPMrObvious is still contributing even after becoming a VIPMrObvious is still contributing even after becoming a VIPMrObvious is still contributing even after becoming a VIPMrObvious is still contributing even after becoming a VIP
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: WinMoSquare - .net cf initialization error

I would install all the .Net CF files you can find for the Diamond because each version is a totally different library. It's like programming a website in PHP4, it's a little older and needs older libraries to work if it won't work in PHP5. I would suggest installing .NET 2 again from a cab and any versions you can find between 2 and 3.5.
__________________
Disclaimer: The truth is obvious.
Reply With Quote
  #5 (permalink)  
Old 06-08-2010, 07:24 PM
horndoctor's Avatar
Suuuper Geeenius
Offline
Pocket PC: hTc RhodiumW (Touch Pro2)
Carrier: Sprint
Location: St. Louis, MO.
 
Join Date: Mar 2009
Posts: 6,764
Reputation: 8384
horndoctor is a trusted member of the communityhorndoctor is a trusted member of the communityhorndoctor is a trusted member of the communityhorndoctor is a trusted member of the communityhorndoctor is a trusted member of the communityhorndoctor is a trusted member of the communityhorndoctor is a trusted member of the communityhorndoctor is a trusted member of the communityhorndoctor is a trusted member of the communityhorndoctor is a trusted member of the communityhorndoctor is a trusted member of the community
Mentioned: 14 Post(s)
Tagged: 0 Thread(s)
Send a message via Yahoo to horndoctor
Wirelessly posted (HTC Diamond: Mozilla/4.0 (compatible; MSIE 6.0; Windows CE; IEMobile 7.11) Sprint MP6950SP)

Quote:
Originally Posted by MrObvious
I would install all the .Net CF files you can find for the Diamond because each version is a totally different library. It's like programming a website in PHP4, it's a little older and needs older libraries to work if it won't work in PHP5. I would suggest installing .NET 2 again from a cab and any versions you can find between 2 and 3.5.
Yeah, that may do it.
Maybe, even if you uninstall the app and the netcf cab you installed and re-install the netcf cab and the netconfig app and soft reset. Then run the config app and set it to run all unconfigured apps with 3.5 then soft reset. Then re-install your winmosquare app.
Reply With Quote
  #6 (permalink)  
Old 07-05-2010, 02:06 PM
designflaw's Avatar
Lurker
Offline
Pocket PC: HTC Diamond
Carrier: Sprint PCS
Threadstarter
 
Join Date: Mar 2009
Posts: 6
Reputation: 10
designflaw is a n00b
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: WinMoSquare - .net cf initialization error

I tried everything you guys had but nothing worked, so I backed up the stuff that I needed and then did a hard reset with the ROM that is on HTC's website. The foursquare app now works. I am happy!
Reply With Quote
Reply

  PPCGeeks > Windows Mobile > WM HTC Devices > HTC Diamond

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


All times are GMT -4. The time now is 11:34 PM.


Powered by vBulletin® ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
©2012 - PPCGeeks.com