PPCGeeks Forums HTC Arrive HTC HD2 HTC Thunderbolt HTC Touch Pro 2 HTC Evo 4G HTC Evo 3D Samsung Galaxy S II Motorola Droid X Apple iPhone Blackberry
Go Back   PPCGeeks > Windows Mobile > WM HTC Devices > HTC Apache > HTC Apache Development

Notices



Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 06-01-2008, 12:29 PM
jnjn's Avatar
N00b
Offline
Pocket PC: apache
Carrier: china telecom
Location: PR China
 
Join Date: Jun 2007
Posts: 34
Reputation: 5
jnjn is a n00b
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Send a message via ICQ to jnjn Send a message via AIM to jnjn Send a message via MSN to jnjn
In case someone has the same problem accessing samba shares with their apache

Samba share access got broken in the recent wm6.1 kitchens for apache. You can access a windows pc share with your apache just fine. Windows pcs can access samba share without a problem too, but you cannot access any samba share with your apache.

You may have googled to find something like add "spnego = no" to your samba server's configuration file or something similar, but they will not work at all.

Here comes the solution.

Change HKLM\Comm\SecurityProviders\NTLM\LmCompatibilityLe vel to 1 from 3, not to 2 (ref: http://msdn.microsoft.com/en-us/library/aa922895.aspx and http://msdn.microsoft.com/en-us/library/aa925018.aspx) as "You can also set the LmCompatibilityLevelServer value to 2 or to 3. Both of these specify that the server will only use NTLM v2. Authentication will fail if the client is not capable of NTLM v2 protocol. For more information, see Authentication Services Registry Settings".

And check to make sure HKLM\Comm\Redir\SmbSignatureMode is set to 0 (not recommended 'cos it may cause problems with windows servers), 1 or 2, but not 3 (ref: http://msdn.microsoft.com/en-us/library/aa921092.aspx).

And you can try to set HKLM\Comm\Redir\AllowedAuthMethods to 3 to see if it makes any difference. To me, 2 works fine.

No need to modify samba configurations if you are running a recent version of samba (3.0.28 right now). Anyway, you can always try to add "use spnego = no" (maybe "client use spnego = no" or "spnego = no" as stated and/or quoted in other posts/web pages, I'm not sure of it.) to see if it makes any difference in your situation/samba version.
Reply With Quote
This post has been thanked 1 times.
Reply

  PPCGeeks > Windows Mobile > WM HTC Devices > HTC Apache > HTC Apache Development

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


All times are GMT -4. The time now is 04:48 PM.


Powered by vBulletin® ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
©2012 - PPCGeeks.com