View Single Post
  #1 (permalink)  
Old 05-04-2008, 04:20 PM
FatFrosty's Avatar
Location: Cincinnati
Join Date: Nov 2007
Posts: 30
Reputation: 85
FatFrosty is becoming a great contributor
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Unhappy SDHC doesn't work

Hello world! I've been good about not posting problems as they're usually already found and fixed until now, and I've been following the scene for probably around a year now.

I just turned in my phone at the local Sprint Store because most of my buttons were worn out, most notably the call button working about half the time. I was in and out in less than 20 minutes with a fresh Mogul.

With this new Mogul, the SD slot works with normal SD cards before I install the SDHC driver. After, neither the normal SD cards work or my SDHC cards. (I know there's problems with regular SD cards and the SDHC driver)

The hardware has to be working, i guess, for the regular SD cards to work so here's what I've tried so far, and in order:

-All custom software (including WM5torage which is a no-no I found out)
-Removed WM5torage from custom Rom (5060)
-Tried on a clean 5060 rom build
-Tried on a clean 5054 rom build
-Tried on a clean 3.35 build
-Installed (the driver) on the device storage with a cab on each build
-Installed on the rom with an OEM (derived from cab) with each build
-Reformatting the cards to FAT and trying again on 3.35

I'm using Vista64 so reformatting the cards to FAT might've done more harm than good if it's FAT16 instead of 32 because it didn't specify which, but then again I didn't reformat until after I tried everything else and they worked perfectly on the mogul I turned in.

Is it possible there's something wrong with the device that stops me from using SDHC (possibly intentionally from Sprint) or is there a thread I completely read over that solves my problems....?
Reply With Quote